[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Please test eglibc 2.9-23+multiarch

On Wed, Jul 29, 2009 at 01:56:40PM +0200, Sven Joachim wrote:
> On 2009-07-28 19:44 +0200, Aurelien Jarno wrote:
> > I have recently uploaded to experimental eglibc 2.9-23+multiarch, from 
> > our multiarch branch. It doesn't use the multiarch paths yet, but it is
> > a first step toward multiarch. 
> >
> > The only difference with the unstable version is that libc-bin and
> > libc-dev-bin are splitted out of libc6 and libc6-dev. This way it
> > complies with the Debian Policy requirement that the libraries should 
> > not contain binaries, which is also a requirement for multiarch.
> >
> > Please test it and report possible problems related to this package
> > split. If no problem are detected, it will be uploaded to unstable as
> > soon as the current version migrates to testing. This way it will leave
> > space in experimental for eglibc 2.10.
> >
> > Note that it is currently not yet available on all architectures, please
> > wait for the experimental buildds to do their jobs.
> I was not patient enough for that and built the packages myself instead
> on i386.  The result is not quite satisfactory, in a Lenny chroot they
> cannot be installed due to a dependency cycle:
> ,----
> | # cat /etc/debian_version 
> | 5.0.2
> | turtle:/# LANG=C apt-get dist-upgrade
> | Reading package lists... Done
> | Building dependency tree       
> | Reading state information... Done
> | Calculating upgrade... Done
> | The following NEW packages will be installed:
> |   libc-bin
> | The following packages will be upgraded:
> |   libc6 libc6-dev locales
> | 3 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
> | Need to get 0B/13.9MB of archives.
> | After this operation, 6042kB of additional disk space will be used.
> | Do you want to continue [Y/n]? 
> | WARNING: The following packages cannot be authenticated!
> |   libc6-dev locales libc6 libc-bin
> | Install these packages without verification [y/N]? y
> | E: Couldn't configure pre-depend libc-bin for libc6, probably a dependency cycle.
> `----
> Same problem with aptitude, and this is the reason: libc6
> 2.9-23+multiarch Pre-Depends on libc-bin (= 2.9-23+multiarch) which in
> turn Depends on libc6 (>> 2.9), so if you didn't have libc6 2.9-x
> already installed, you're hosed.

Thanks, it's something I forgot to test, I only tested squeeze to
experimental upgrades.

I have been told offline that the "Pre-Depends:" also breaks
debootstrap, so it should probably be switched to a Depends.

"Pre-Depends:" has been chosen because two binaries are important in
libc-bin and we have to make sure to not break the system:
- /sbin/ldconfig which is used to configure the ld.so cache. It should
  not be necessary during an upgrade as ld.so is smart enough to look by
  itself in the standard paths if the cache is out of date. If a package
  rely on ldconfig to add a new search path in is postinst, it should 
  depends on libc6 and thus on libc-bin, and that is enough to ensures
  that /sbin/ldconfig is there.
- /usr/lib/pt_chown is used to change the permissions of the terminal
  when grantpt(3) is called. On GNU/Linux, it is only useful if /dev/pts
  is not mounted, and if one wants to login as non-root. On GNU/kFreeBSD
  it is not used due to the use of devfs.

In short it looks like a Pre-Depends is overkill, and that a Depends is 
enough. I'll upload a new version soon to experimental to fix that.


Aurelien Jarno                          GPG: 1024D/F1BCDB73
aurelien@aurel32.net                 http://www.aurel32.net

Reply to: