[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RC bug for >10 packages

* Adeodato Simó [Sat, 25 Oct 2008 18:57:55 +0200]:

>   Package: apertium
>   Provides: apertium-pcre-1

> And then, each time you detect a new incompatible version of pcre, you
> make apertium Provide: apertium-pcre-2.

This is of course fragile, so you may want to go for:

   Package: apertium
   Depends: ${shlib:Depends}, libpcre3 (<< 7.X+1)
   Provides: apertium-pcre-1

And then apertium needs an extra upload for each new 7.X version of
pcre, after checking whether or not it breaks compatibility.

Adeodato Simó                                     dato at net.com.org.es
Debian Developer                                  adeodato at debian.org
                        Listening to: Madeleine Peyroux - Reckless blues

Reply to: