[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Debian-med-packaging] Bug#503367: plink: file conflict with putty-tools

On Sat, Oct 25, 2008 at 12:24 PM, Charles Plessy <plessy@debian.org> wrote:
> Both programs are intended for command line, and could be used in
> scripts. We may even find users who want to install both at the same
> time. Very annoying…
> Since Plink is younger than Putty, I think that the burden of the
> renaming is for us (the Debian Med packaging team). I plan to rename
> /usr/bin/plink to /usr/bin/Plink, that would be a symbolic link to
> /usr/lib/plink/plink so that with an appropriate PATH, users can rescue
> their scripts.

Since renaming seems to be the only solution, than IMO it is more
appropriate to rename 'plink' in putty-tools than in the plink
packages since this is exactly the source/binary package name. This
has been done already in putty-tools for the 'puttygen' binary.


piti:~# dpkg -L putty-tools

Reply to: