[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems packaging a kernel using cdbs

Ah, I see. the initrd is created at install time, not at .deb package building time.

I inspected the generated .deb file and indeed, there is no initrd.img in the .deb file - the initrd is created when you actually install the package on the target system, which means it's the target system that needs to have the yaird or initramfs tools.

So what I don't understand is that on this system, I am unable to install the .deb file unless yaird is installed.

yaird is not working for me because of this:

yaird error: Could not read output for /sbin/modprobe -v -n --show-depends --set-version evdev (fatal)
mkinitrd.yaird failed to create initrd image.

I tried uninstalling yaird and setting the INITRD_CMD=initramfs-kpkg, (which is installed already) but the built .deb file still seems to require initrd.yaird, because I get this error:

Unpacking linux-image- (from linux-image- ...
Could not find mkinitrd.yaird. at /var/lib/dpkg/tmp.ci/preinst line 240, <STDIN> line 9.
Finding valid ramdisk creators.
Failed to find suitable ramdisk generation tool for kernel version

On the TARGET system, it seems to prefer initrd

On 3/26/07, Warren Turkal <wt@atmos.colostate.edu> wrote:
On Monday 26 March 2007 12:09, Alan Ezust wrote:
> I tried building using make-kpkg with --initrd binary options, and ended
> up with a cpio archive. Why? I have no idea.

An initramfs is a cpio archive.

I am assuming that are you referring to the file created after the kernel is
installed. Is that correct?

Warren Turkal

Reply to: