[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libraries being removed from the archive

Today I was reminded of something that causes apps not to migrate into
sarge.  When maintainers remove old libraries from the archive!  Today
for example libexif8 was removed by Christophe Barbe and replaced by
libexif9.  Guess what that does... any package which depends on libexif8
now becomes... you guessed it... UNINSTALLABLE!  Why does this annoy me
in particular, because I just uploaded kdegraphics yesterday which was
built against libexif8. Guess how many hours it takes for the m68k
buildd to rebuild kdegraphics..... OVER 38 HOURS!

IMHO we need to make an addition to policy stating that an old lib can
not be removed from the archive until no other packages still depend on

Chris Cheney

Reply to: