[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SASL/LDAP/DB dependency hell.



* Junichi Uekawa (dancer@netfort.gr.jp) wrote:
> I wouldn't consider them nasty hacks.

You'd be wrong.

> Well, then, they are ld feature, not universally available.

That's correct, amazingly enough.

> I could not convince libpng maintainers to use versioned symbols because
> they were apparently not available on AIX and Windows.

Then they're being fools.  As with a great deal of other things (which
is why we have things like automake/autoconf and company) versioned
symbols should be used on the platforms that support them and ugly hacks
where they're not supported.  The ugly hacks shouldn't be forced on
current systems due to the poor design of ancient and archaic systems.

	Stephen

Attachment: pgps2hqcETeP9.pgp
Description: PGP signature


Reply to: