[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SASL/LDAP/DB dependency hell. (was: Accepted cyrus-sasl 1.5.27-3.4 (i386 source))



* Andreas Metzler (ametzler@logic.univie.ac.at) wrote:
> Actually it is much simpler, many packages are simply not compileable
> anymore:
> 
> libldap2-dev depends on libsasl-dev [1]
> libsasl-dev depends on libdb2-dev (>= 2.7.7.0-7) [2]
> libdb3-dev conflicts with libdb2-dev
> 
> [1] introduced in response to #164791
> [2] introduced in response to #168993
> 
> libtool strikes again, quoting from the report
> | /usr/lib/libsasl.la contains -lpam as a dependency, so -lsasl can't be
> | linked using libtool without libpam0g-dev being installed.

Going back to this I realize I didn't look into this carefully enough.
libsasl-dev should not be depending on libdb2-dev, if it is then
something's fucked up, and it sounds like it's libtool.  I've heard
there is work being done to fix this obvious and blatent fuckage so
trying to come up with a way to support this is not necessary.

	Stephen

Attachment: pgp7cMa4hbETS.pgp
Description: PGP signature


Reply to: