[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

more and more broken packages?

it looks like there are more and more broken packages. I have been using unstable for few years and generally there were no problems, all packages where upgradable, no version mismatch etc.

however over time the quality went sharply down (during last 6 month - year?), to the point of debian being routinely unupgradable (automatically, using either aptitude u-g-g or apt-get update && apt-get dist-upgrade). there are various conflicts etc. and I can only make it work (somewhat) by removing packages, sometime dpkg --remove (apt-get remove doesn't seem to work, it stops because of the problem I am trying to fix)

e.g. today I was hit by: gftp-common, gftp-text, gftp-gtk (maybe not all of them, see #176188: gftp-gtk needs to conflict with gftp-common, #176206: gftp-gtk: apt-get upgrade from 2.0.13-1 fails)

somehow I managed to get them uninstalled (notice that there is basically no way for user to figure out what's going on, which package is old and which one is new, from bug reports it seems that gftp-common is an old one).

  now I still have the following packages on hold (uninstallable):

ih balsa		2.0.5-1   2.0.5-2
ih gedit		2.0.6-1   2.1.6-1
ih libdbd-pg-perl	1.20-1    1.20-2
ih libgd1		1.8.4-20  1.8.4-30
ih libgnomevfs2-common	2.0.4-4   2.1.91-2
ih libgssapi1-heimdal	0.4e-22   0.4e-23
ih libkrb5-17-heimdal	0.4e-22   0.4e-23
ih libnautilus2-2	2.0.8-1   2.1.91-1
ih libpgperl		7.3rel-8  7.3.1-5
ih libpgtcl		7.3rel-8  7.3.1-5
ih libsigc++-dev	1.0.4-3   1.0.4-5
ih nautilus		2.0.8-1   2.1.91-1
ih pd			0.34.2-4  0.36.cvs-3
ih postgresql		7.3rel-8  7.3.1-5
ih postgresql-client	7.3rel-8  7.3.1-5
ih postgresql-contrib	7.3rel-8  7.3.1-5
ih sasl2-bin		2.1.9-5   2.1.10-1

  as far as I can tell each of them is broken:

  balsa: Depends: libaspell15 but it is not going to be installed
  gedit: Depends: libaspell15 but it is not going to be installed

and libaspell conflicts with other versions of libaspell (I guess, when I try to install libaspell15 it wants to remove other versions of libaspell* and bunch of other programs that depend on these other versions).

  nautilus: Depends: libeel2-2 (>= 2.1.91) but 2.0.8-2 is to be installed
Depends: libnautilus2-2 (>= 2.1.91) but 2.0.8-1 is to be installed

  pd: Depends: libjack0.34.0-0 (>= 0.34.0) but it is not installable

  and then:

E: Package libjack0.34.0-0 has no installation candidate

and more of the same with the rest of the packages (I didn't investigate every single of them)

I understand that this is unstable but considering nature of debian releases unstable is only usable version of debian for desktop/workstation, at least for people who want at least sort of current software (stable is beyond ancient, not sure how good is testing now but I had problem during time I tried testing, it had same/m,ore bugs as unstable and it took longer to fix them). and unstable used to be VERY stable (of all the packages I had installed most of the time NONE were broken)

why do developers upload packages that clearly cannot be installed? I mean I understand that from time to time there is a problem but current situation is quite bad and it seems to be getting worse.

so does the de facto status of unstable change from 'usable with caution' to 'scratchpad for developers'? How is the situation of testing now? is that the one that unstable used to be (=current enough and stable enough)? (I mean the real state of testing, not what it's supposed to be)

any info on what's going on appreciated (and no, it's the unstable, stupid, doesn't count, for the reasons mentioned above).


Reply to: