[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Build-depends on archaic versions of software wrong!

>>>> "DS" == David Starner <dstarner98@aasaa.ofe.org> writes:

DS> A couple package, sawfish and gnome-core, now have versioned
DS> dependencies on gettext according to the changelogs; <= 0.10-35-17
DS> and = 0.10.35-17. 

DS> These are not reasonable dependencies for Debian! Debian unstable is
DS> 0.10.36-1. It is a serious bug for both of them to have
DS> unfulfillable build-dependencies. The fact that sawfish has a bad po
DS> file that 0.10.36 rejects is a bug in sawfish, not gettext. Whether
DS> the problem with bug 93198 is, dependening on an older version of
DS> gettext is not the solution; try fixing the bug in gnome-core or
DS> gettext.

This bug 93198 isn't related to the build depend on gettext 0.10.35-17.

To see why I've did that see bug 92932

Quoting this bug:

"Explanation: Some Korean users are using an UTF-8 locale, not an"
"EUC-KR locale. If the msgstr is not correct EUC-KR, the conversion"
"to UTF-8 will fail, and these users will see garbage on their screen."
"Also, since the msgstr is not valid EUC-KR, the EUC-KR users will"
"probably also see garbage on their screen."

Then I've 2 solutions :

1) Build-depends on gettext 0.10.35-17

2) Remove all po files who cause problem.

I prefer the first solution.

Another problem, xml-i18n-tools doesn't work with the latest gettext, and
this package is needed by all Gnome 1.4 packages. A fix can be easily

I think a lot of packages will not compile because of the latest gettext.

The best solution for now is to depends on gettext 0.10.35 and wait to see
if the latest gettext is needed in woody.


Reply to: