[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Build-depends on archaic versions of software wrong!

On Sat, 07 Apr 2001, Christian Marillat wrote:
> Then I've 2 solutions :
> 1) Build-depends on gettext 0.10.35-17
> 2) Remove all po files who cause problem.

3a) fix it properly, by recoding the broken entries. May require help of a
korean speaker.
3b) fix it properly, by removing the broken entry and filling a bug
4) fix it improperly, by static-linking old gettext in the binary, and
including it in the .diff. Expect some LART if you do this... but at
least it means you do not trouble other packages.

(1) is not acceptable. Ugly hacks (that may affect the entire system) to cut
corners are not welcome, unless they're actually the only possible solution.
This is IMHO, but I expect a lot of people (some of them who did need to fix
their packages to work with the new gettext) to agree...

> I think a lot of packages will not compile because of the latest gettext.

Then a lot of packages will need to be fixed. We are NOT in deep freeze

Latest gettext will not "break" anything that is not broken to begin with,
AFAIK... it just won't let you get away with the breakage anymore.

> The best solution for now is to depends on gettext 0.10.35 and wait to see
> if the latest gettext is needed in woody.

Best for Debian as a whole? IMHO, not.  Best for your package? No, it did
not fix the problem, nor worked around the real breakage.  Best for your
users? No, how is the message getting correctly displayed if its encoding is

Do your job *right*, even if that means it will take a while until the next
upload. Or ask for help.

  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh

Attachment: pgptXS3l6vPAJ.pgp
Description: PGP signature

Reply to: