Build-depends on archaic versions of software wrong!
A couple package, sawfish and gnome-core, now have versioned
dependencies on gettext according to the changelogs; <= 0.10-35-17
and = 0.10.35-17.
These are not reasonable dependencies for Debian! Debian unstable is
0.10.36-1. It is a serious bug for both of them to have
unfulfillable build-dependencies. The fact that sawfish has a bad po
file that 0.10.36 rejects is a bug in sawfish, not gettext. Whether
the problem with bug 93198 is, dependening on an older version of
gettext is not the solution; try fixing the bug in gnome-core or
In general, when libc/libncurses/gcc/g++/gettext/ some other
"build-base" package changes major versions, and it breaks your
package (due to a "feature" change), you're going to have to fix it
in your package, not try to depend on the older version.
Is ever reasonable to have versioned dependecies that a newer
version of the package won't fufill outside packages from the same
source? Maybe two tightly coupled packages, perferably with the
same Debian maintainer, would qualify, but gettext and
gnome-core/sawfish shouldn't be tightly coupled.
David Starner - firstname.lastname@example.org
Pointless website: http://dvdeug.dhis.org
"I don't care if Bill personally has my name and reads my email and
laughs at me. In fact, I'd be rather honored." - Joseph_Greg