[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kill -9 -1 from non-super user in X hangs Debian

>> In article <[🔎] 33C39450.1D82@student.uni-tuebingen.de>,
>> Falk Hueffner <falk.hueffner@student.uni-tuebingen.de> wrote:
>> >When I type "kill -9 -1" as a non-super user in an xterm, the system
>> >hangs. The mouse won't move, and I can't change to a virtual console. I
>> >don't know if I can still login via telnet, since I have no network
>> >connection.
>> So? You just killed all your own running processes, including the X
>> server. The X server runs with an effective user id of root, but with
>> your real uid so you are allowed to kill it.
>Not a really helpful answer as it also locks up the terminal after X dies
>which is obviously a problem. I have tried this on my machine, but I run

I haven't actually tried it, but I would guess that the reason the
machine appears to lock up when you kill -9 the X server is that then
it doesn't get a chance to restore the video and keyboard to ascii mode. 
The way to unlock the machine would be to log in from elsewhere and
open a new virtual terminal (for example: open /bin/login).

The only way to get this not to happen requires kernel hacking, and
it's probably not worth the effort. Every platform I've used behaves
strangely when the X server i kill -9:ed (though some are more easily


PS. The reason it doesn't lock up when you use xdm is that you don't own
the X server in that situation, it is owned entirely by root and thus
resets cleanly when your session terminates. It shouldn't even exit.

 -- Of course I'm crazy, but that doesn't mean I'm wrong.
Anders Hammarquist   |          This space          | iko@netg.se
NetGuide Scandinavia |   intentionally left blank   | Fax: +46 31 50 79 39
http://www.netg.se   |                              | Tel: +46 31 50 79 40

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: