[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Daily netinst still fail with "No kernel modules found"

Hey Holger!

On Fri, Jan 29, 2021 at 11:30:21PM +0100, Holger Wansing wrote:
>Holger Wansing <hwansing@mailbox.org> wrote:
>> "Rick Thomas" <rick.thomas@pobox.com> wrote:
>> > Where should I look for one that's more up-to-date?
>> On https://www.debian.org/devel/debian-installer/
>> you should look under the daily snapshots.
>> For armhf that would be
>> https://d-i.debian.org/daily-images/armhf/daily/netboot/SD-card-images/
>Hmm, that's curious!
>When trying images from today, the netboot ones are working, but the
>netinst images are still failing with "no kernel modules found" error.
>Interestingly, the netboot image has an linux kernel v5.10.0-2 running
>on it (that's ok), but on the netinst image I have a v5.9.0-4 !!!
>Some research with old netinst images show these kernel versions:
>	20201115	5.9.0-2
>	20201130	5.9.0-4
>	20201203	5.9.0-4		that's alpha3 release
>	20210115	5.9.0-4
>	20210129	5.9.0-4
>So, there is something wrong with some of the dailys (netinst, maybe more...)
>Do we still get the alpha3 builds copied to daily, or something like that?

I think I've found the bug. I've been refactoring CD image builds and
it looks like I missed a configuration setting. We were not picking up
on the daily d-i builds, instead using the stuff from the archive. :-(

I'm just about to trigger a daily build by hand now with the fix, and
that should hopefully solve the problem.

Steve McIntyre, Cambridge, UK.                                steve@einval.com
There's no sensation to compare with this
Suspended animation, A state of bliss

Reply to: