[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing Debian Buster on Cubox-i4 with eSATA drive.

On Thu, Jan 28, 2021, at 12:08 AM, Rick Thomas wrote:
> On Wed, Jan 27, 2021, at 11:15 PM, Vagrant Cascadian wrote:
> > On 2021-01-27, Rick Thomas wrote:
> > > I'm trying to install Debian Buster [1] on my Cubox-i4P with an eSATA
> > > drive. Everything seems to be fine, but when it comes time to reboot,
> > > it boots into the installer again, rather than the installed system.
> > >
> > > Here's what I did, and what I observed:
> > >
> > > *) I downloaded the two parts of the SDcard install image from [1] and followed the instructions in the README to create a 4GB (I didn't have anything smaller) SDcard installer.
> > > *) I connected the eSATA disk and plugged the SDcard into the Cubox and powered it up.
> > > *) It booted off the SD-card into the installer as expected.
> > ...
> > > *) But when the reboot happened, I found myself back in the installer.
> > > *) I tried removing the SDcard and rebooting, but it failed to boot -- after power-on nothing happened.
> > 
> > > What I hoped would happen with the eSATA drive was that the installer
> > > would write the boot firmware (u-boot, etc) to the SDcard, and
> > > configure it to get /boot, root, /home, swap off the eSATA.
> > 
> > U-boot can only be loaded from microSD on that platform, as far as I'm
> > aware.
> > 
> > You can use the bootloader from the installer image, just delete the
> > boot.scr and/or extlinux.conf from the partition on the installer image,
> > or make another partition on the microSD card, and mark it bootable, but
> > don't put anything on it. Then u-boot should fall back to loading the
> > kernel+initrd+device-tree off of the eSATA.
> > 
> > If you interrupt the boot process and get to a u-boot prompt, you should
> > be able to see the order of devices u-boot tries to boot from with:
> > 
> >   printenv boot_targets
> > 
> > 
> > Now that bullseye is in the early phases of freeze, please consider
> > testing bullseye, too, if you can! :)
> Thanks!  This sounds like it ought to work.  I'll give it a try.
> For bullseye, where should I download the latest installer image from?  
> I'd love to give it a try as well!
> Rick

That worked!

Specifically, what I did was:
*) on a different machine, I mounted the installer SDcard first partition
*) renamed boot.scr to oboot.scr
*) sync and umount the SDcard.
*) inserted it in the Cubox
*) powered up and watched it boot from the eSATA disk.


*)     => printenv boot_targets
       boot_targets=mmc0 sata0 usb0 pxe dhcp

*) It located the /boot partition on the eSATA drive without any help from me.  I assume that means it goes down the list of boot_targets one by one looking for an active bootable partition containing a file called "boot.scr" which it then executes to perform the remainder of the boot process (mostly to load the kernel and initrd , then pass control to them).

*) I wonder if it would be possible to change the "boot_targets" environment variable to put "sata0" first?  Would that work, if it could be done?  If that were done, would it mess up booting from the SDcard when there was no eSATA drive?

So now, the next question is: how do we convince the debian installer to recognize that it's installing to the eSATA drive and either set "boot_targets" appropriately, or mark the boot partition on the SDcard as not bootable.

I've added "debian-boot" to the CC list of this email.  Should I file a bug report?  If so, what package should I file it against?

Next thing to test -- can I install bullseye the same way?

Thanks very much to everyone for all your help!

Reply to: