[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#607480: The same error on Asus 1215N

On 01/11/2011 05:58 PM, Miguel Rentes wrote:
> Thank you Len, I'll grab the latest snapshot and try it :) I'll then
> tell you if I succeded.

Huh. I thought I had reports from our (Debian Eee PC's) users that this
worked with beta2, so I'm not sure using the latest snapshot would make
anything better. See my earlier link to notes in our wiki on 1215P, as
there are specific suggestions there as to what needs to be done to make
it work: including specifying acpi_osi="Linux" boot parameter, and the
firmware is apparently necessary to make *both* wifi and ethernet work.
This might be another manifestation of #573607 which unfortunately would
need yet another exception made to disable hotplugging for that specific
model# (not a great solution because new models keep coming out,
requiring an exception to be made for each one).

If that's the case, ultimately the solution is to replace eeepc_laptop
with eeepc_wmi. I worked with upstream testing a backport he made for
2.6.32 but there are so many things that this would break at this point
(plus it requires a patch to the acpi module to even work) that it's
kind of too late to think about including this in Squeeze. :(

> On 11 January 2011 19:51, Lennart Sorensen <lsorense@csclub.uwaterloo.ca> wrote:
>> I just spotted this:
>> 2.6.32-28 changelog:
>>   * atl1c: Add support for Atheros AR8151 and AR8152 (Closes: #599771)
>> Did you use the latest installer snapshot, or the beta2 or what?
>> Certainly the version in the current images you can download for beta2
>> have the new version of the driver for the atl1c and should work.
>> Anything older than December 20th will not work for sure.

Lennart, how do you figure Dec. 20th? 2.6.32-28 migrated to testing Nov.
28th according to PTS ...


Reply to: