[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#607480: The same error on Asus 1215N

On Tue, Jan 11, 2011 at 09:51:52AM +0000, Miguel Rentes wrote:
> Hi everyone,
> I got for Christmas a new Asus 1215N and I'm trying to install Debian
> testing (I'm using debian-squeeze-di-beta2-amd64-netinst.iso on a USB
> stick) with no sucess. When I get to the part when the installer tries
> to find the ethernet card, it fails miserably with the message "No
> ethernet card detected" and then asks me to choose from a list of
> drivers. This netbook uses an Atheros AR8152 Wired card and a Broadcom
> BCM4313 Wireless card. Both cards are not detected. I have chosen the
> driver atl1c from the list of drivers and again the installer cannot
> find and use the AR8152 wired card. I tried to choose the broadcom
> driver and it also can't use the wireless card either. Can you please
> help me and tell me what should I do to install Debian?
> Right now I skipped the Network configuration part and have a minimum
> base Debian installation on my netbook and tried to compile the atl1c
> driver with no success. I copied to the USB stick the compat-wireless
> bzip2 archive and was trying to compile it but I don't even have the
> bzip2 installed and tar fails miserably to extract this package... I
> even tried to use a different .iso on the USB stick but when I use
> "zcat boot.img.gz > /dev/sdf" to my USB pen, which has 2GB in size, it
> gets truncated to 256MB and the only .iso file I can copy at this
> point to the USB stick is the squeeze-di-beta2-amd64-netinst.iso.
> I don't know what else to do right now.

Could you get the PCI id of the network devices?

lspci -n |grep 02[08]0
should get them both.

Using those will make it easier to look up which driver in which kernel
supports them (if any).

You should be able to run that from the console during the installer
(left alt+F2 or left control+alt+F2).

I believe the driver for the wired port is atl1c, but you need at least
2.6.36 kernel to have one new enough for your chip version.  AR8152 was
added to atl1c Feb 16, 2010.

No idea about the broadcom.  My experience with broadcom has always
been awful.

Len Sorensen

Reply to: