[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [g-i] fonts: a few thoughts


> I have tried removing all the Arabic unicode range from FreeSerif and
> removing all the other available fonts but the Arabic one. I don't know
> what I've done wrong, but the problem remains...

I've done some progresses while focusing my attention on Arabic glyphs:
problem is with FreeSansBold.ttf and in particular the following  Arabic
glyphs ranging from U+0617 to U+0633 and after removing those Arabic
text looks more like [1].

[.. time goes on..]

I tried to rebuild a g-i image removing the gplyphs just mentioned but I
do not get the same result I got in my previous tests... I'm sure we're
not far from fixing this though.

if you're guessing how I run my previous tests, here's it is:
I chrooted in tmp/gtk-miniiso/ and, I removed the freefonts
files one after the other and run "fc-cache -vf" before restarting
debconf . Once I removed FreeSansBold.ttf Arabic looked right,
so I looked at it and found the glypsh mentioned above.

If you (adn?) make any progress on this, please keep up to date


[1] http://adn.diwi.org/tmp/d-i-arabic.png

Reply to: