[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: OldWorld floppy images

On Fri, Mar 26, 2004 at 01:50:21PM +0100, Jeremie Koenig wrote:
> On Fri, Mar 26, 2004 at 03:40:38AM +0100, Sven Luther wrote:
> > I commited this stuff yesterday to SVN.
> Thanks !

No problem. I have also been in contact with the bemac shop to get hand
on a oldworld pmac myself, if the occasion presents itself.

> > Two problems remain now, one of them not being all that important
> > maybe.
> > 
> >   1) miboot and rsrce need to be packaged. Can you provide us with a
> >   status report on this one, and maybe we can help with the legal stuff ?
> The packages need to be polished. About the legal stuff, I haven't
> received an answer for a week. Maybe reminder time ?

We can do the polishing later, no problem with that, polishing is best
done once the package is in use, and receive testing anyway. For the
legal stuff, definitely a reminder is ok, and please CC me about it, or
one of the lists. Who is the upstream anyway ? 

> >   miboot and rsrce need to be added to the build-dependencies too then.
> Only the interface provided by miboot is used. Rsrce is just a
> dependency for miboot.

Yeah, but it depends on the rsrce package, which is nowhere available.

> >   BTW, i couldn't find the rsrce package on your archive, where did you
> >   put it, and did you already get a sponsor to upload it to the archive ?
> http://sprite.fr.eu.org/dist/debian, just as miboot. But I just remarked
> that some version of miboot is lying around in /dist, I'll have to do
> some housekeeping :-)

Oh, ok, understood then.

> I haven't got a sponsor. Maybe you can upload it once I've polished it a
> bit ?

Yes, altough as said, we can upload rsrce right now, and maybe work
together on polishing or whatever is needed. This is a dependency for
d-i on oldworld, so it is rather urgent. rsrce is legaly ok, and
depended upon by miboot, so nothing is stopping us from uploading it.

> >   2) -boot, -boot-ofonly and -root don't build properly when building on
> >   a system running a 2.6 kernel. The problem being during the depmod
> >   phase, which dies with :
> > 
> >     depmod: QM_MODULES: Function not implemented
> The Makefile seems to call depmod when creating the tree and
> VERSIONED_SYSTEM_MAP is defined, but after a quik grep -r, I fail to see
> how this could be the case...

Needs investigation, maybe someone else will comment.

Anyway, thanks again for your work on this.


Sven Luther

Reply to: