[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: updated powerpc debian-installer builds

I tried both of the powerpc images from gluck.debian.org today.  Let
me know if any of these problems should be bugs.

First I tried the business card iso. I didn't actually burn an iso,
since I don't have a burner at home, so let me tell you how I do this
in case it's relevant. I create an Apple_HFS partition on my hard disk
/dev/hda19 (200 MB) and then:

mount -t hfs /dev/hda19 /mnt/cd-fake
hformat /mnt/cdfake
mount -t hfs -o loop xxx.iso /mnt/iso
cp -pR /mnt/iso/* /mnt/cd-fake/
# put the boot files at the root of the partition
cp /mnt/cd-fake/install/powermac/* /mnt/cd-fake

Then I edit the yaboot.conf to point to hd:19 instead of cd: and
remove the paths to vmlinux and root.bin, and boot manually from OF:

boot hd:19,yaboot

This works to boot, choose language, and detect a keyboard/choose
layout. Next I tried to detect CDROM devices and mount the CD. 
It's not surprising it doesn't work, since I don't actually have
a CD in the drive.

I tried mounting my partition at /cdrom, but the kernel doesn't
have hfs compiled in. I think we need to correct this, powerpc
users will always want to be able to access hfs partitions on
their drive.

I'm assuming we'll be able to install from a hard drive mirror
just as we could with boot-floppies, right?

If I get a chance to burn a CD at work, I'll try it with a real CD.

I tried the netinst iso next, but got about the same results.
When I switched to console 2, there was a repeating message:

modprobe: modprobe: Can't locate module net-pf-1

That might explain why there weren't any Configure Network items
in the menu.

I assume you're still the one building these guys, thanks!

Debian GNU/Linux Operating System
  By the People, For the People
Chris Tillman (a people instance)
   toff one at cox dot net

Reply to: