[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#52073: Problem installing the Operating System Kernel and Modules

Package: boot-floppies
Version: 2.1.9
architecture: i486
model: IBM
memory: 8M
scsi: none
cd-rom:       none
network card: none
pcmcia:       bay in place, but no card present
disk:         540M IDE

I have tried every permutation known to man to install Debian to no avail. I get dbootstrap to work all right -- so I must be using rawrite2 properly to create the disk images. I get the files system initialized and mounted to /. Then I try to actually install the Operating System Kernal and Modules from /dev/fd0; I insert the Rescue Floppy in the drive and (occasionally) get: "Cannot read /floppy/type.txt : Invalid argument." What I always get are the next messages: "Mount failed; unable to mount the rescue floppy" and then "Floppy error; The attempt to extract the Rescue Floppy failed." I have tried re-downloading the floppy images dozens of times. I tried the resc1440tecra.bin as well, all with the same result.

I even repartitioned the drives so as to have a FAT16 partition; I then used a DOS recovery disk to copy files to the FAT16 partition. I then successfully ran install.bat, which loaded up the Debian linux dbootstrap program from the FAT hard disk. But, I get the same error when I try to load up from floppies. And I dont seem able to copy the base disks over to the hard drive. When I try to mount the floppy device, I get an error. If I try to copy the disk image over under DOS, it can't see the file I created for base14_1.bin (naturally, as it isn't a DOS compatible format). I even tried to toggle the DOS compatibility feature of "mount" from the thin shell under dbootstrap. But none of these permutations have met with any success.

Are there any suggestions? I can't seem to come up with another workaround. (CD is out -- not wanting to plow money into a CD when I don't know if the unit will work with Debian).

Really, somehow or other the floppies ought to work. They work for everything else I have ever done, so I find it hard to believe that this is all "buggy hardware" as the installation suggests.

Thanks again,

Darryl Rothering

Get Your Private, Free Email at http://www.hotmail.com

Reply to: