[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#52073: Problem installing the Operating System Kernel and Modules

"Darryl Röthering" <drothering@hotmail.com> writes:

> I have tried every permutation known to man to install Debian to no avail. I 
> get dbootstrap to work all right -- so I must be using rawrite2 properly to 
> create the disk images. I get the files system initialized and mounted to /.

Huh? I don't understand this last part.  Aren't you booting off the floppies?
> Then I try to actually install the Operating System Kernal and Modules from 
> /dev/fd0; I insert the Rescue Floppy in the drive and (occasionally) get: 
> "Cannot read /floppy/type.txt : Invalid argument." What I always get are the 
> next messages: "Mount failed; unable to mount the rescue floppy" and then 
> "Floppy error; The attempt to extract the Rescue Floppy failed." I have 
> tried re-downloading the floppy images dozens of times. I tried the 
> resc1440tecra.bin as well, all with the same result.

The rescue images are msdos file systems.  Are you able to see them as
msdos file systems?  All dbootstrap really does is mount the disk,
then run install.sh on it.

Since you're not having a boot problem per se, I can only imagine that
either (a) the archives have corrupted stuff on them (?!)  (b) you are
having problems making floppies at all -- but then, how could you boot
off them?

> I even repartitioned the drives so as to have a FAT16 partition; I then used 
> a DOS recovery disk to copy files to the FAT16 partition. I then 
> successfully ran install.bat, which loaded up the Debian linux dbootstrap 
> program from the FAT hard disk. But, I get the same error when I try to load 
> up from floppies. And I dont seem able to copy the base disks over to the 
> hard drive. When I try to mount the floppy device, I get an error. If I try 
> to copy the disk image over under DOS, it can't see the file I created for 
> base14_1.bin (naturally, as it isn't a DOS compatible format). I even tried 
> to toggle the DOS compatibility feature of "mount" from the thin shell under 
> dbootstrap. But none of these permutations have met with any success.

You can do a floppyless install if you have an existing DOS
installation...  Copy the images and install.bat in drivers.tgz and
linux and all that as described in the manual, and load from DOS...

> Really, somehow or other the floppies ought to work. They work for 
> everything else I have ever done, so I find it hard to believe that this is 
> all "buggy hardware" as the installation suggests.

Are you saying that are are able to create floppies for other stuff
and it works fine, therefore it can't be your hardware?

I could help better if I can understand what you are doing.  Take
you're simplest case that is not working, and describe the steps you
are taking, i.e.,

 make rescue disk from resc1440.bin
 make drivers disk from drv1440.bin
 copy base2_1.tgz and other req'd files to DOS partition
 boot from rescue disk

.....Adam Di Carlo....adam@onShore.com.....<URL:http://www.onShore.com/>

Reply to: