[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Strech on TS-109 (Orion) Stucks

Hi Martin,

On 22/02/2018 22:24, Martin Michlmayr wrote:
> * Arthur Lutz <arthur@lutz.im> [2018-02-22 21:51]:
>> I've added some info to
>> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=890262#51 but this
>> might be a different problem.
> They are different.  The bug report is about the size issue.
Sorry about putting this in the wrong place.
>> So I tried with the initrd and kernel from the stretch installer from
>> http://ftp.debian.org/debian/dists/stretch/main/installer-armel/current/images/orion5x/network-console/qnap/ts-109/
>> I tried with the padding for the kernel as suggested in
>> http://www.cyrius.com/debian/orion/qnap/ts-109/recovery/  (dd if=kernel
>> of=kernel.pad ibs=2097152 conv=sync) but that is obviously not useful.
> Padding the kernel won't make a difference.  Padding the kernel is
> only required when creating a recovery image because you're combining
> several files into one.

Yep, thanks for the formal explanation.

>> In the end, I got it to boot to installer with
>> http://ftp.debian.org/debian/dists/jessie/main/installer-armel/current/images/orion5x/network-console/qnap/ts-109/
>> I now have to find out how to do the equivalent of grub-upgrade on the
>> previous kernel. But while I'm in this state, I can help out debug this
>> problem.
> This blog entry might help:
> http://www.cyrius.com/journal/debian/installer-flash-kernel
> Instead of update-initramfs run flash-kernel and the version of the
> kernel.
Yes, I managed to do the equivalent. By the way I tried the 4.13 kernel
from backports and it had the same behaviour as the 4.9. So I went back
into the installer and removed both 4.x kernels and flash-kernel
correctly re-flashed the 3.x one. Which works fine !

> Now as to why the stretch kernel doesn't work for some people... I'm
> pretty sure the ARM kernel has EARLY_PRINTK enabled so you could try
> adding earlyprintk to the cmd line options.
> Take kernel and ramdisk from
> http://ftp.debian.org/debian/dists/stretch/main/installer-armel/current/images/orion5x/network-console/qnap/ts-109/
> setenv bootargs console=ttyS0,115200n8 earlyprintk root=/dev/ram rw initrd=0x800000,0x3fffff
> tftpboot 0x0800000 initrd
> tftpboot 0x400000 kernel
> bootm 0x400000

Oh, sorry, I was kind of hyped that it rebooted correctly in 3.x, that I
forgot my offer and disconnected the serial cable and closed the
enclosure. If this is usefull to others, I can test that out in the next
few days.


ps. by the way Martin, thank you so much for your efforts to get debian
working on this and the sheevaplug, I have been following your
documentation for years and it's just awesome!

Reply to: