[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: Strech on TS-109 (Orion) Stucks

* Arthur Lutz <arthur@lutz.im> [2018-02-22 21:51]:
> I've added some info to
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=890262#51 but this
> might be a different problem.

They are different.  The bug report is about the size issue.

> So I tried with the initrd and kernel from the stretch installer from
> http://ftp.debian.org/debian/dists/stretch/main/installer-armel/current/images/orion5x/network-console/qnap/ts-109/
> I tried with the padding for the kernel as suggested in
> http://www.cyrius.com/debian/orion/qnap/ts-109/recovery/  (dd if=kernel
> of=kernel.pad ibs=2097152 conv=sync) but that is obviously not useful.

Padding the kernel won't make a difference.  Padding the kernel is
only required when creating a recovery image because you're combining
several files into one.

> In the end, I got it to boot to installer with
> http://ftp.debian.org/debian/dists/jessie/main/installer-armel/current/images/orion5x/network-console/qnap/ts-109/

> I now have to find out how to do the equivalent of grub-upgrade on the
> previous kernel. But while I'm in this state, I can help out debug this
> problem.

This blog entry might help:
Instead of update-initramfs run flash-kernel and the version of the

Now as to why the stretch kernel doesn't work for some people... I'm
pretty sure the ARM kernel has EARLY_PRINTK enabled so you could try
adding earlyprintk to the cmd line options.

Take kernel and ramdisk from

setenv bootargs console=ttyS0,115200n8 earlyprintk root=/dev/ram rw initrd=0x800000,0x3fffff
tftpboot 0x0800000 initrd
tftpboot 0x400000 kernel
bootm 0x400000

Martin Michlmayr

Reply to: