[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: NSLU2 (Slug) fails to boot with second drive connected

I put a 2 in the fstab due to some comments in the man page.

The sixth field, (fs_passno), is used by the fsck(8) program to  deter-
      mine the order in which filesystem checks are done at reboot time.  The
      root filesystem should be specified with a fs_passno of  1,  and  other
      filesystems  should  have a fs_passno of 2.  Filesystems within a drive
      will be checked sequentially, but filesystems on different drives  will
      be  checked  at  the  same time to utilize parallelism available in the
      hardware.  If the sixth field is not present or zero, a value  of  zero
      is  returned  and fsck will assume that the filesystem does not need to
      be checked.

When I ran "mount -a" I got the following error.

[mntent]: line 9 in /etc/fstab is bad

This line of course corresponded to the last line in the file or the
line that was not mounting.  I messed with some various options and I
now have it working with the following line.

/dev/sda1       /disk2          ext3    defaults        0      2

I think this is strange as a previous email had me run a command
cfdisk /dev/sda and it returned that it was an NTFS partion yet I did
format it with mkfs.ext3 when I reformatted the disk the other day.

Now it is mounting automatically on boot.

Thank everyone who have helped.

On 6/18/07, Bob <bob@bjerremose.com> wrote:
Aaron Klein wrote:
> I tried the following which is the last part of the directions for
> mounting with UUID's.
> Then update the initramfs:
> $ sudo update-initramfs -u
> and flash the new initramfs
> $ sudo flash-kernel
> Even with both drives having UUID's in /etc/fstab and then doing the
> above two commands after putting both drives in the /etc/fstab fiile
> when I reboot it still does not automount the second disk.

>> > # /etc/fstab: static file system information.
>> > #
>> > # <file system> <mount point>   <type>  <options>       <dump>  <pass>
>> > proc            /proc           proc    defaults        0       0
>> > UUID=b0beb15a-1e86-40f9-996e-1d58d3bd1936       /
>> ext3    defaults
>> > ,errors=remount-ro 0       1
>> > /dev/sda5       none            swap    sw              0       0
>> > /dev/sda1       /media/usb0     auto    rw,user,noauto  0       0
>> > /dev/sda5       /media/usb1     auto    rw,user,noauto  0       0
>> > /dev/sda1       /disk2          ext3    defaults, errors=remount-ro
>> 0      2

The last parameter of the /disk2 mount line in your fstab is the number 2.
I don't recall ever using that number there, only 0 or 1 - mostly 0.
Maybe that is the problem. You could try ato add "auto" to the options
string, but I think "defaults" is supposed to include that.
Then again, I'm no expert in the fstab syntax.

Does disk2 mount manually after boot when you type "mount -a" ?


To UNSUBSCRIBE, email to debian-arm-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Have pets?  Get the help you need from the Pet Advice Network.
We have 6 websites ready to help you.  http://www.petadvice.net

Reply to: