[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem with NICs on Amd64 installer

On Thursday 10 November 2005 19:01, Lennart Sorensen wrote:
> On Thu, Nov 10, 2005 at 06:45:43PM +0000, David Goodenough wrote:
> > I am new to Amd64, but have been using Debian for a long time.
> >
> > I was asked to install Debian on a couple of 1U servers running AMD-64
> > CPUs.  They have NICs that require the TG3 driver.
> >
> > I got hold of the sid D-I business card ISO, and booted it up.  It booted
> > just find and correctly identified the need to load the TG3 driver.  But
> > it then failed to load it, and if I change to the second console and try
> > to use modprobe explicitly it says that the TG3 driver is not found.
> >
> > Now I know there was a problem with the TG3 driver in that it required
> > binary firmware, but I understand that there is now a version which
> > does not need the firmware but does not enable all the facilities.
> >
> > Having failed with that driver I then tried to plug in a USB ethernet
> > adapter which would have needed the pegasus driver.  But that is
> > not auto-detected and again not loadable.
> >
> > There is a PCI slot spare, but it does not seem designed for
> > ethernet cards in that I don't think I can get connected to it.
> >
> > Any ideas?
> What model is the machine?  If the expansion slot isn't PCI or PCI-X
> what is it?  It probably won't allow an old 5V PCI card, but any dual
> voltage card (two notches in the PCI connector rather than only one)
> should fit in any PCI slot.  PCI express is different of course.
> You can try my 2.6.12 sarge installer for amd64 and see if the tg3
> driver it has works any better/differently.
> http://www.tinyplanet.ca/~lsorense/amd64/
I tried this but it did not help.  In fact it also does not seem to have the
driver for the RAID card in it, so I could not even install without the 

I also tried the most recent etch-rc1 ISO, and that fails in the same way.

I am confident that the ethernet cable is correctly installed and that the
connection to the hub is working as the relevant panel light comes on both
in the front of the machine and on the hub.  The driver loads apparently
correctly, and ifconfig reports a device.  dhclient tries to get an address
but fails, and if I statically configure the card it accepts the values but
then fails to communicate.

Anyone have any further ideas?


> Len Sorensen

Reply to: