[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Anyone tried the ASUS A8V-E Deluxe?

Javier Kohen wrote:

Hi Kyuu,

Kyuu Eturautti wrote:

Thank you for the tip. I can now confirm that the A8V-E Deluxe onboard NIC will function with kernel versions up to 2.6.9 but not with 2.6.10 or .11. After I set up 2.6.9, I ran the install.sh script that came with the driver from syskonnect.com and generated a patch, which I applied on the kernel sources. The other installation options (expert and user) did not work. I tried all of the install options on 2.6.11, 2.6.10 and 2.6.9, and only 2.6.9 worked.

It seems I'm stuck with 2.6.9 for this particular motherboard. A newer linux driver is clearly needed from syskonnect / marvell. The nature of the errors (functions pci_save_state and pci_restore_state) might indicate functionality added in 2.6.10. I wouldn't know, I'm not a coder.

I have no idea whether this will help you, but kernel 2.6.10 prints the following message on start up:
PCI: Using ACPI for IRQ routing
** PCI interrupts are no longer routed automatically.  If this
** causes a device to stop working, it is probably because the
** driver failed to call pci_enable_device().  As a temporary
** workaround, the "pci=routeirq" argument restores the old
** behavior.  If this argument makes the device work again,
** please email the output of "lspci" to bjorn.helgaas@hp.com
** so I can fix the driver.

I think it won't hurt you to try.


Thank you. I tried this as well yesterday, without results. I've also attempted some other common kernel parameters, such as acpi=off and noapic. Tried a load of BIOS settings as well as enabling/disabling several bus and system options in the kernel.

However, I don't believe kernel parameters or BIOS settings will help, as everything works fine up until 2.6.9, but the syskonnect.com driver just will not compile with newer kernel versions.


Reply to: