[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Anyone tried the ASUS A8V-E Deluxe?

On Sun, Mar 06, 2005 at 02:03:56AM +0200, Kyuu Eturautti wrote:
> Thank you for the tip. I can now confirm that the A8V-E Deluxe onboard 
> NIC will function with kernel versions up to 2.6.9 but not with 2.6.10 
> or .11. After I set up 2.6.9, I ran the install.sh script that came with 
> the driver from syskonnect.com and generated a patch, which I applied on 
> the kernel sources. The other installation options (expert and user) did 
> not work. I tried all of the install options on 2.6.11, 2.6.10 and 
> 2.6.9, and only 2.6.9 worked.
> It seems I'm stuck with 2.6.9 for this particular motherboard. A newer 
> linux driver is clearly needed from syskonnect / marvell. The nature of 
> the errors (functions pci_save_state and pci_restore_state) might 
> indicate functionality added in 2.6.10. I wouldn't know, I'm not a coder.
> I hate saying it, but every time I buy an Asus motherboard, I face a lot 
> of problems. It's happened now seven times in a row...twice this week 
> alone. I guess this is what can be called human-hardware incompatibility.

Hmm, how odd.  I have never had a problem with Asus boards, and I have
quite a few (haven't bought anything else since 1992).

It seems odd that a driver working in 2.6.9 stops working in newer
versions, so someone changed something in a way that broke it, and
perhaps not just on Asus, although given how common they are, I guess
Asus being the best known for encountering this problem does make sense.
I wonder if there is anything different about how Asus connects this
chip, or if they are just using a newer/older revision than other boards
(assuming other boards have sk98lin onboard and not just cheap

Len Sorensen

Reply to: