[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Anyone tried the ASUS A8V-E Deluxe?

On Sat, 2005-03-05 at 18:11 +0200, Kyuu Eturautti wrote:
> Wesley J Landaker wrote:
> >On Friday, 04 March 2005 21:07, Kyuu Eturautti wrote:
> >  
> >
> >>Alois Zoitl wrote:
> >>    
> >>
> >>>Hi,
> >>>
> >>>i got this htin g yesterday and I'm not to glad about it because I
> >>>can not get the network running.
> >>>As far as I found out it uses also the sk98lin driver.
> >>>But the standard driver that comes along with the debian amd 64 cd
> >>>fails the installation.
> >>>After using an additional card I was able to upgrade to the gcc-3.4
> >>>tree. And after installing
> >>>the 2.6.9-9 kernel I could load the sk98lin module with modconf.
> >>>But I don't think its working.
> >>>      
> >>>
> >>I've hit the same problem on the same board. Running a freshly
> >>installed pure64 sarge.
> >>
> >>- the driver on the DFS cd states No adapter found
> >>- the driver in 2.6.11 from ftp.kernel.org doesn't do anything -
> >>modprobe sk98lin doesn't report anything on the console or dmesg.
> >>modules are working, as I can load the 3c59x module without problems
> >>for a temporary alternate nic
> >>    
> >>
> >
> >The sk98lin driver in the kernel doesn't work with this motherboard. 
> >Instead, you must use the one from:
> ><http://www.syskonnect.com/syskonnect/support/driver/htm/sk9e21_lin.htm>
> >
> >(The module is GPL'd, and AFAICT is the same driver as what is in the 
> >kernel, except MUCH MUCH newer... so who knows why it isn't in the main 
> >kernel tree.)
> >
> Yes, I figured as much, but as I also noted, it doesn't work either. 
> Quoting myself:
> - the latest driver from syskonnect.com fails during "Compile the 
> kernel" when running install.sh, either expert or user mode. The 
> install.log contains these errors:
> -- In function 'sk98lin_resume';
> -- error: too many arguments to funcion 'pci_restore_state'
> -- a similar error for sk98lin_resume and function pci_save_state
> If needed, I can provide more details.
> /v\

I ran into these same problems when trying to install Sarge on my Asus
A8V and created a bug report
(http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=292445).  To get
around it, I downloaded an install disc from a couple of months ago.  I
don't remember which exact one.  The bug must have been introduced in a
later version of the kernel, because I was then able to get the network
card to work so that I could install the OS.  Then after the OS was
installed, I upgraded to the latest kernel and everything worked fine.


Reply to: