[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Hmmm! (was Re: Netboot on Multia)

On Sun, Feb 25, 2007 at 12:10:14AM -0600, Harmon Seaver wrote:
>     What is happening is the same problem Marc reported, except my nic
> is going down earlier. The syslog says it can't resolve the mirrors
> address, at this point, but going back all the way thru syslog, I see
> dhclient is trying discovers way back. The install initially gets it's
> ip and connection okay, but seems to lose it back about when I start
> seeing stuff about: "net/hw-detect.hotplug: Detected hotpluggable
> network interface. In the meantime it has downloaded a lot of stuff,
> goes ahead and unpacks and installs it -- all the while there are
> unanswered dhcp requests.  AND NO RECORD OF THOSE requests in my servers
> logs.
>    From the shell I've tried modprobe de2104x and it's loaded, and eth0
> is up, and I can run dhclient, but no blinks from the hub or nic. I've
> even tried unlugging the cable, downing eth0, bringing it back up, all
> that stuff. No go.

Hmm, tough.

Well, the best I can offer at this point is to include the existing de4x5
module, as-is, in the nic-modules package and allow users to load it by hand
before the installer tries to auto-detect.  Not pretty, but probably the
best workaround I can offer at this stage of the release process.

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon@debian.org                                   http://www.debian.org/

Reply to: