[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Hmmm! (was Re: Netboot on Multia)

Steve Langasek wrote:
> On Sat, Feb 24, 2007 at 01:42:59AM -0600, Harmon Seaver wrote:
>>   Well, this is really weird. Maybe there's a bug in the latest install.
>> I tried a number of times to install etch on my multia's 340mb internal
>> scsi drive but each time it quit right after trying to install
>> initramfs-tools. Tried going to a shell and deleting all the packages in
>> /target/var/cache/apt/archives, but couldn't get the install to proceed,
>> it just wanted to install the whole base again, and wouldn't do that
>> unless I reformatted the partitions.
>>    Anyway, got sick of that, so got my old external scsi case out of the
>> attic, put a 1.8gb drive in that -- and it's old and ugly and horribly
>> noisy, but I figured at least I could get a good install and also have
>> room to recompile stuff, etc. and later move a smaller system over to
>> the internal drive. So -- started the install again, repartioned the
>> 1.8gb into 1mb for aboot, 20mb for boot (ext2), 128mb for swap, and the
>> rest for / -- ext3.
>>     So, guess what? The install crashed at the exact same place -- when
>> trying to install initramfs-tools.

   Okay, just did the exact same thing again, this time with 30mb boot.

> What is the error in the logs when this fails?

    What is happening is the same problem Marc reported, except my nic
is going down earlier. The syslog says it can't resolve the mirrors
address, at this point, but going back all the way thru syslog, I see
dhclient is trying discovers way back. The install initially gets it's
ip and connection okay, but seems to lose it back about when I start
seeing stuff about: "net/hw-detect.hotplug: Detected hotpluggable
network interface. In the meantime it has downloaded a lot of stuff,
goes ahead and unpacks and installs it -- all the while there are
unanswered dhcp requests.  AND NO RECORD OF THOSE requests in my servers
   From the shell I've tried modprobe de2104x and it's loaded, and eth0
is up, and I can run dhclient, but no blinks from the hub or nic. I've
even tried unlugging the cable, downing eth0, bringing it back up, all
that stuff. No go.
   Wasn't there a problem with this same driver back in an earlier
release -- seems like I remember having to manually install the de4x5
driver back in sarge or woody, because they came with de2104x or
something else that didn't work on Mulitias.
    And I should say that I've never noticed the nic on my multia being
flakey otherwise, other than the above situation.
    I wish I had done this install on the serial console so I could give
you the whole syslog, but ....
    If it's really needed, I could do another install that way just to
get the syslog, but it's really a pain, this thing is so slow.

> It's possible that 20MB isn't enough for boot when using the default
> initramfs config, I guess, but we'd need to see the logs to do anything
> beyond blind guessing.  (FWIW, my /boot is 19MB, and this is pretty tight
> even with MODULES=dep in /etc/initramfs-tools/initramfs.conf -- it's not
> enough space to keep two kernels with initrds installed, and still have
> room for an initrd rebuild on kernel upgrade.)

Harmon Seaver

Reply to: