[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Hmmm! (was Re: Netboot on Multia)

On Sat, Feb 24, 2007 at 01:42:59AM -0600, Harmon Seaver wrote:
>   Well, this is really weird. Maybe there's a bug in the latest install.
> I tried a number of times to install etch on my multia's 340mb internal
> scsi drive but each time it quit right after trying to install
> initramfs-tools. Tried going to a shell and deleting all the packages in
> /target/var/cache/apt/archives, but couldn't get the install to proceed,
> it just wanted to install the whole base again, and wouldn't do that
> unless I reformatted the partitions.
>    Anyway, got sick of that, so got my old external scsi case out of the
> attic, put a 1.8gb drive in that -- and it's old and ugly and horribly
> noisy, but I figured at least I could get a good install and also have
> room to recompile stuff, etc. and later move a smaller system over to
> the internal drive. So -- started the install again, repartioned the
> 1.8gb into 1mb for aboot, 20mb for boot (ext2), 128mb for swap, and the
> rest for / -- ext3.
>     So, guess what? The install crashed at the exact same place -- when
> trying to install initramfs-tools.

What is the error in the logs when this fails?

It's possible that 20MB isn't enough for boot when using the default
initramfs config, I guess, but we'd need to see the logs to do anything
beyond blind guessing.  (FWIW, my /boot is 19MB, and this is pretty tight
even with MODULES=dep in /etc/initramfs-tools/initramfs.conf -- it's not
enough space to keep two kernels with initrds installed, and still have
room for an initrd rebuild on kernel upgrade.)

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon@debian.org                                   http://www.debian.org/

Reply to: