[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: booting on a microway alpha box

On Tue, Jul 23, 2002 at 03:39:49PM -0500, Douglas Fils wrote:
> Jay, Jon, thanks for the responces...
> I am booting from AlphaBIOS/milo (can I install SRM in it's place, it
> sounds like the better option).  The milo version is older,
> (v2.0.35-c5.4, but I have tried new milo's off CD and they don't seem to
> help)
> once in milo a show command tells me that I have fd and ide devices.  I
> seem to have SCSI installed on the machine, but not used, the devices
> are IDE.
> If I "ls hdb0:" in milo I see I need to list the boot directory to see
> linux, so I used...
> boot hdb0:/boot/linux root=/dev/hdb0
> (I've tried /dev/hdb for root as well)

/dev/hdb0 is a more likely candidate than /dev/hdb.  How is your disk

> This boots the kernel but gets to:
> ---
> Freeing unused kernel memory: 184K free
> Waring: unable to open initial console
> Kernel panic: No init found Try passing init= option to kernel
> ---

That sounds as if the filesystem isn't arranged the way that linux is
expecting it...  Do you have a / and /boot setup?  If so, then the
root directory needs to be /dev/hdb1 or /dev/hdb2, or...  If you ls
various partitions in MILO, does the rest of the filesystem look the
way you expect?  In particular, is there a sbin/init on /dev/hdb0?

You might also try passing init=/bin/sh or something like that, just
for debugging purposes.

Which kernel are you trying this with?  I need to install some new
hardware in my system sometime soon, and if you're still stuck I can see
if I can reproduce the problem on my system.

> at this point I have tried a number of different combination, but seem
> to not be able to fall on the correct one, hoping to find help here..

Jon Leonard

To UNSUBSCRIBE, email to debian-alpha-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: