[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: booting on a microway alpha box

Jay, Jon, thanks for the responces...

I am booting from AlphaBIOS/milo (can I install SRM in it's place, it
sounds like the better option).  The milo version is older,
(v2.0.35-c5.4, but I have tried new milo's off CD and they don't seem to

once in milo a show command tells me that I have fd and ide devices.  I
seem to have SCSI installed on the machine, but not used, the devices
are IDE.

If I "ls hdb0:" in milo I see I need to list the boot directory to see
linux, so I used...

boot hdb0:/boot/linux root=/dev/hdb0
(I've tried /dev/hdb for root as well)

This boots the kernel but gets to:
Freeing unused kernel memory: 184K free
Waring: unable to open initial console
Kernel panic: No init found Try passing init= option to kernel

at this point I have tried a number of different combination, but seem
to not be able to fall on the correct one, hoping to find help here..


On Tue, 2002-07-23 at 15:01, Jon Leonard wrote:
> On Tue, Jul 23, 2002 at 02:44:16PM -0500, Douglas Fils wrote:
> > 
> > I've been searching FAQ's and the net for information about booting a
> > microway alpha workstation. (currently running RedHat 6.2)
> > 
> > EB164 (lx164 variation) 
> That sounds like the system I have, which gives me very little trouble
> booting...
> I did have trouble booting 2.4 kernels until I set the legacy kernal option
> (CONFIG_ALPHA_LEGACY_START_ADDRESS=y) because I have an older MILO, but
> if you're trying to boot a 2.2 kernel that's not it.
> I also set my root device on the command line, because I've built at least
> one kernel where the default was wrong.
> > I can get the system to start the boot, uncompress kernel and begin the
> > boot process with Debian 3.0 and 2.2.
> > However, I get either kernel frezes on boot or failure to init and I've
> > tried all sorts of kernel init/root boot prompt options.
> > 
> > Has anyone been successfull on a microway alpha box eb164(lx164) and if
> > so can you tell me what your boot command from milo looked like?
> The contents of two relevant /proc files:
> frost:~# cat /proc/cpuinfo
> cpu                     : Alpha
> cpu model               : EV56
> cpu variation           : 0
> cpu revision            : 0
> cpu serial number       : Linux_is_Great!
> system type             : EB164
> system variation        : LX164
> system revision         : 0
> system serial number    : MILO-2.0.35-c5.
> cycle frequency [Hz]    : 600000000
> timer frequency [Hz]    : 1024.00
> page size [bytes]       : 8192
> phys. address bits      : 40
> max. addr. space #      : 127
> BogoMIPS                : 1191.08
> kernel unaligned acc    : 361582386 (pc=fffffc0000533914,va=fffffc000064cd81)
> user unaligned acc      : 2687 (pc=120000db0,va=11fffe994)
> platform string         : N/A
> cpus detected           : 0
> frost:~# cat /proc/cmdline
> bootdevice=sda3 bootfile=vmlinuz.experimental root=/dev/sda3
> If forget exactly how that looks from a MILO prompt (I don't reboot often),
> probably something like "boot sda3:/vmlinuz.experimental root=/dev/sda3".
> If that doesn't help, some more details about exactly how it is freezing
> and the last messages from the kernel would help in debugging.
> Jon Leonard

To UNSUBSCRIBE, email to debian-alpha-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: