[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Headless install on LX164

Adam C Powell IV <hazelsct@mit.edu> writes:
> > Unfortunately my memory is a bit foggy.  I think you have to change the
> > console device on the root floppy so it looks like:
> >
> > $ ls -l /dev/console
> > crw--w--w-    1 root     tty        5,   1 Nov  6 05:41 /dev/console
> Cool!  How can I do that?  I tried mounting the ramdisk image floppy, but that
> was obviously wrong...  Do I have to somehow MAKEDEV in the root floppy /dev?

Its most likely a .gz file. Unpack it and you get an ext2 filesystem.

> > I believe that the one on the floppy is a symlink to /dev/tty.
> Really?  Any idea on why this is?  Seems like a proper /dev/console shouldn't
> take up that much space, and would make life easier for folks like me. :-)
> (Then again, it sounds like the new boot floppies are quite starved for space,
> counting every byte...)
> Goswin Brederlow wrote:
> > Adam C Powell IV <hazelsct@mit.edu> writes:
> >
> > > Any hope?  With the slink boot floppies, I load the ramdisk from
> > > root.bin floppy and then get confirmation that it mounted root, and
> > > recommendation that e2fsck be run, then nothing.  I don't suppose
> > > there's a way to get dbootstrap to use a serial console...
> >
> > Hmm, you should be able to set the initial console at the boot prompt
> > via "tty=XXX". Serial console should be fine there.
> tty=what?  I tried tty=/dev/ttyS0 which is the serial line where the console is,
> but got the same message as above- can't open initial console.

Maybe /dev/ttyS0 isn´t present on the boot floppy and thus can´t be


Reply to: