[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Headless install on LX164

Greg Johnson wrote:

> On Tue, Nov 23, 1999 at 11:50:38PM +0000, Adam C Powell IV wrote:
> > Hello again,
> >
> > Okay, so I tried taking the linux kernel off the rescue floppy and
> > replacing it with the Northern Linux one which came with the machine, so
> > it definitely has the serial console compiled in.  Rebooted, and it
> > gives me:
> >
> > VFS: Insert root floppy disk to be loaded into RAM Disk and press ENTER
> > <did that>
> > RAMDISK: Compressed image found at block 0
> > VFS: Mounted root (ext2 filesystem) readonly.
> > Freeing unused kernel memory: 120k freed
> > Warning: unable to open an initial console.
> > EXT2-fs warning: checktime reached, running e2fsck is recommended
> >
> > Why can't it open an initial console?  It has no problem doing so when
> > booting from the same kernel on the hard drive.  Any ideas?  Has anyone
> > installed Debian on headless LX164?
> I have.  A while ago.


> Unfortunately my memory is a bit foggy.  I think you have to change the
> console device on the root floppy so it looks like:
> $ ls -l /dev/console
> crw--w--w-    1 root     tty        5,   1 Nov  6 05:41 /dev/console

Cool!  How can I do that?  I tried mounting the ramdisk image floppy, but that
was obviously wrong...  Do I have to somehow MAKEDEV in the root floppy /dev?

> I believe that the one on the floppy is a symlink to /dev/tty.

Really?  Any idea on why this is?  Seems like a proper /dev/console shouldn't
take up that much space, and would make life easier for folks like me. :-)
(Then again, it sounds like the new boot floppies are quite starved for space,
counting every byte...)

Goswin Brederlow wrote:

> Adam C Powell IV <hazelsct@mit.edu> writes:
> > Any hope?  With the slink boot floppies, I load the ramdisk from
> > root.bin floppy and then get confirmation that it mounted root, and
> > recommendation that e2fsck be run, then nothing.  I don't suppose
> > there's a way to get dbootstrap to use a serial console...
> Hmm, you should be able to set the initial console at the boot prompt
> via "tty=XXX". Serial console should be fine there.

tty=what?  I tried tty=/dev/ttyS0 which is the serial line where the console is,
but got the same message as above- can't open initial console.

> > By the way, what's up with the installation docs?  Chapter 6 seems to
> > know nothing about AlphaBIOS!  No MILO boot parameters, just "put in the
> > (floppy/cd) and it will work," which is bogus.  I had to check my
> > vendor's floppy install option for RedHat rescue in order to boot the
> > Debian rescue disk.
> >
> > There really should be something in there explaining how to configure
> > the AlphaBIOS or pass the options via MILO.  And the options should
> > really be in there too!  I used:
> >
> > boot fd0:linux root=/dev/fd0 load_ramdisk=1 prompt_ramdisk=1
> Add your tty there as well and it should work.

Cool.  How does one go about suggesting including these in the install

> May the Source be with you.

And also with you.  :-)

Thanks much,

          Adam Powell                     http://lyre.mit.edu/~powell/
          Thomas B. King Assistant Professor of Materials Engineering
          77 Massachusetts Ave. Rm. 4-117         Phone (617) 452-2086
          Cambridge, MA 02139 USA                   Fax (617) 253-5418

Reply to: