[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Headless install on LX164

On Mon, Nov 29, 1999 at 04:17:35AM +0000, Adam C Powell IV wrote:
> Hmm, I have a 2.2 kernel from the Northern Linux install (RedHat derivative) and
> just tried that console=ttyS0 boot line option, but no success, same "unable to
> open an initial console". :-(

Right, with 2.2.x you need a console device with major number 5 and
minor number 0.  The install ramdisk has 4,1 (I think).

> > ftp://physics.clarku.edu/users/gjohnson/root1440.bin.serial
> Slurped through real slow download (~45 minutes, and I have a 10 Mbps connection!),
> made the disk, and...

Yeah, I forgot to mention that our T1 is completely saturated here. :-(

> IT WORKED!!  Thank you, Thank You, THANK YOU!!  I haven't finished installing yet
> (it's real slow on an ancient Tek 4207 terminal where I have to slog through the
> VT220-related errors), but I got through disk partitioning and it's looking good!

Great!  Glad it worked. :-)

> "Let me buy you a drink!  Let me buy you a whole fleet of drinks!!" -Londo Mollari
> in Signs and Portents
> But seriously, Greg, I owe you big time.

No problem. 

> This serial console image would be a great addition to the install floppies!

It should work out of the box on potato with "console=ttyS0" on the
command line.  I assume the console device on the new boot floppies is
(5,0).  2.2.x kernels handle this. 

> I'll post again if the whole install comes through, and if not, then I guess I'll
> post again anyway... :-)

Cool, let us know. 

> Zeen,
>             Adam Powell                    http://lyre.mit.edu/~powell/

Greg Johnson                          gjohnson@physics.clarku.edu
http://physics.clarku.edu/~gjohnson            finger for PGP key

Reply to: