[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sudden death of bluetooth headphone connectivity

On Sat, Aug 05, 2017 at 05:27:49PM +0200, deloptes wrote:
> Can you try bluetoothctl and see if it connects properly.
> you can also post the output of "info <bt addr>"

[NEW] Controller 00:1B:DC:04:DB:FA kazuki [default]
[NEW] Device 8C:8E:F2:C2:BD:93 iPhone
[NEW] Device 00:09:A7:09:BE:22 BeoPlay H8
[NEW] Device F0:CB:A1:89:68:61 Mark's Phone
[NEW] Device 4C:A5:6D:7E:0E:FC Mark's tablet
[NEW] Device A0:E9:DB:09:A0:2D Anker SoundCore
[bluetooth]# connect 00:09:A7:09:BE:22
Attempting to connect to 00:09:A7:09:BE:22
Failed to connect: org.bluez.Error.Failed
[bluetooth]# info 00:09:A7:09:BE:22
Device 00:09:A7:09:BE:22
        Name: BeoPlay H8
        Alias: BeoPlay H8
        Class: 0x240418
        Icon: audio-card
        Paired: yes
        Trusted: yes
        Blocked: no
        Connected: no
        LegacyPairing: no
        UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
        UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
        UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
        UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
        UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)
        UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
        Modalias: bluetooth:v0103p4000d0802

That's what I get when I try to connect -- a less than helpful error 
message. The same error message as quoted before appeared in the systemd 
journal when I make the connection attempt.

And the output of info <addr> is quoted above as well. I am wondering if 
among the UUIDs listed should be a2dp-sink, and since we are not getting 
it it is getting booted. But as we know from the journal entry, 
a2dp-sink protocol is "not available" -- and I think that remains the 
issue to fix to get this working.

Overall I am inclined to think something is misconfigured / broken / 
missing in the _computer_'s bluetooth setup, not the headphones -- as 
the headphones work fine with other devices eg my iPhone, and for anyone 
coming late into the conversation they also worked with this computer 
too until about 2 weeks ago now.


Reply to: