[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sudden death of bluetooth headphone connectivity

On Thu, Aug 03, 2017 at 08:35:23PM -0300, Henrique de Moraes Holschuh wrote:
> On Fri, 04 Aug 2017, Mark Fletcher wrote:
> > suddenly stopped working. I didn't do an apt autoremove last Sunday, but 
> > may have done one the Sunday before -- which would have been reckless 
> The log files are at:
> /var/log/apt*
> /var/log/apt/*
> Failing that:
> /var/log/dpkg*
> It will list everything that was updated, installed, removed, or purged.
> -- 

OK I had a look in /var/log/apt/ folders at the history.log files. In 
the one for July I determined that I ran an apt upgrade on July 16th, 
one week before my trip, and the next time I did so was on July 29th, on 
my return from my trip. So I displayed more restraint around updates 
just before travelling than I remembered. In the week between July 16th 
and July 23rd when I left for my trip, I definitely used the headphones, 
so they were working after the July 16th update.

No update on July 23rd, which actually makes sense because I was up at 
5:30am to catch a plane. I might have done the update the day before, 
but it seems i did not.

The upgrade record for July 29th has a long list of packages I will have 
to go through in detail. I have already noticed both pulseaudio and udev 
got updates so those are 2 possible candidates for the culprit. I seem 
to recall there was also a kernel upgrade, meaning I would have rebooted 
after the upgrade.

Next in the apt log is this:

Start-Date: 2017-07-29  23:46:36
Commandline: apt autoremove
Requested-By: mark (1000)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2017-07-29  23:46:41

[the dpkg error code is a red herring, I have zoneminder installed but 
it requires access to a mysql database, and due to a previous unrelated 
problem with my local mariadb instance, zoneminder's database is in read 
only mode, so zoneminder can't start properly -- that is the cause of 
the error code]

Am I reading that correctly that I ran apt autoremove and it didn't find 
anything to do? Or is it just not telling me what it did?

I also looked in /var/log/dpkg.1 (July's stuff is already partially 
archived) and:

grep 2017-07-29 /var/log/dpkg.1 | awk '{print $3}' | sort -u 

lists the following keywords:


No sign of "remove", but I don't know if there would be or not...

So IF I am interpreting the above correctly, I ran apt autoremove but it 
didn't do anything, I did upgrade a shedload of packages and the next 
thing to do is to sift through that shedload looking for changes 
(somehow) that might have caused the problem. I'm not really sure how I 
am going to tell what changes a package upgrade made, unless the 
changelog happens to mention something useful, but hopefully something 
will turn up... I'll start with packages that look pulseaudio or 
bluetooth-related, and go from there...


Reply to: