[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Alternative for printer-driver-cups-pdf?

Brian <ad44@cityscape.co.uk> writes:

> On Tue 02 May 2017 at 20:04:55 +0200, Felix Natter wrote:
>> hello Brian,
> Hello Felix.

hi Brian,

>> Brian <ad44@cityscape.co.uk> writes:
>> > On Tue 02 May 2017 at 18:12:18 +0200, Felix Natter wrote:
>> >
>> >> does anybody know an alternative for PDF printing (from any application
>> >> that can print) to printer-driver-cups-pdf?
>> >> 
>> >> The output of printer-driver-cups-pdf (in jessie and sid)
>> >> is really bad, see:
>> >> http://www2.inf.fh-brs.de/~fnatte2s/freeplane.pdf
>> >> (might not be viewable by in-browser pdf-viewer, save and open with
>> >> evince/okular to see the broken content: jagged edges, useless font rendering)
>> >> 
>> >> The application I am using (Freeplane 1.6) cannot produce PDFs on its
>> >> own (due to incompatibility with the new SVG rendering).
>> >> 
>> >> There was a bug #847462, but it's resolved and didn't seem to help.
>> >> 
>> >> Any hints?
>> >
>> > brian@desktop:~$ file freeplane.pdf 
>> > freeplane.pdf: PostScript document text conforming DSC level 3.0
>> >
>> > Do you want to start again? :)
>> I tried renaming the file to freeplane.ps, and get the same result when
>> viewing with evince ;-)
> Which you would. Renaming the file does not alter its contents. The
> point is that freeplane file has not been produced by cups-pdf. It is
> not (as you assert) the output of printer-driver-cups-pdf.
>> > What application produced this PostScript file?
>> Freeplane, a java mind map editor. I strongly assume that this is the
>> built-in java printing functionality. A screenshot of the printing
>> dialog is attached.
> If freeplane produced the PostScript file it is highly unlikely any
> post-processing of it would produce any better output.

Makes sense, yes. On the other hand, Freeplane's print preview looks
just fine.

> The print dialog is not quite gtkprint (see the one for Firefox or
> Evince). Whatever it is doing, it does not appear to be producing a PDF
> with the PDF printer it displays. (Producing a PDF is the raison d'être
> for cups-pdf).

Yes, if I do not select [x] Print to File, no output is produced. So it
looks like the openjdk print dialog is broken, or wrongly used.

The print preview in Freeplane looks fine, though. So I will have a look
at the source code and maybe work with the openjdk people on fixing

Many Thanks and Best Regards,
Felix Natter

Reply to: