[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: boot fails on jessie on Acer Travelmate

Hi again,

On 03/12/14 08:56, Pierre Couderc wrote:
Le 03/12/2014 07:58, Simon Hollenbach a écrit :
you might want to dig further into this,
Mmm, what is my other choice ? W8 ?  Ubuntu ?
I was talking about reporting a bug when you don't know what's wrong. But indeed, there are other choices if you want them, I don't, right now, and as we are talking about this on a Debian support list, discussing them here would be imho inappropriate anyway.

as I can't see how a developer could fix the error you are
experiencing without more information.
But I am ready to spend hours to fix that !
Wht is needed ?
Further information. But what you provided in your other mail, the partition layout, seems to be a good start, maybe even enough to solve your problem, not the installer's/GRUB's. I'll come back to that.

When exactly does the boot-up stall? You don't even see the GRUB menu,
do you?
I am not sure what is the grub menu, but if it is the blue menu asking
which debian version to load. I do not arrive there.
It isn't blue any more at my place, it's skinned with a Debian logo aso, but yes, the menu that lets you select a boot-mode/kernel/os . It starts with "GRUB loading..." and then "Welcome to GRUB" iirc, followed by aforementioned menu.

In fact, it seems  to me that the disk is not read, but it tries to net
Why do you think it tries to boot from a network?

Have you tried with another boot loader? Last time I installed, LILO
was still available for selection from expert install iirc. If the
system boots with LILO, you would have narrowed down the problem quite
a bit.
No, sorry, I am not enough expert. If this is a regression in GRUB, it
must be solved, one way or another.
Debian wheezy works fine on this computer. Jessie has worked too, but no
more today.
I don't consider myself an expert either, the "expert install" just asks more stuff, explained very well imo. Maybe just try it next time you install or on a spare machine.

Again, I don't think filing a bug without any info but "it doesn't
work" will get your problem solved.

I am not able to find the bug myself. I am ready to spend hours to fix
it, but I need the help of someone to tell me where to  search...
I think we got a differing understanding here. I think you just encountered a bug, or you did something really stupid, which shouldn't happen if you sanely try to install Debian. We got to describe the bug now, so it can be fixed.

Now my solution attempt, it worked for me once (but like 3 years ago)

On 03/12/14 11:19, Pierre Couderc wrote:
> One big difference is that after jessie installation boot flag has
> disappeared : gpt :
> wheezy :
> Number  Start   End    Size    File system     Name  Flags
>   1      1049kB  512MB  511MB   fat32                 boot
> jessie :
> Number  Start   End    Size    File system     Name  Flags
>   1      1049kB  538MB  537MB   fat32
Why don't you toggle the bootable-flag on your /boot-partition by hand? It happened to me that this was the only thing that was wrong after installing. I did it with fdisk, run it from a rescue CD, specifying your disk /dev/sda as parameter:
# fdisk /dev/sda
Then, you hit [p] to print the partition table of sda, start counting from 0 until you find your boot partition, it should be 0, according to the gpt output. Then hit [b] to toggle the bootable flag on a partition and select the partition you just identified as your /boot-partition.

Finally, write the changes to disk with [w], which also exits fdisk. Then reboot and, if you want, cross your fingers...


Reply to: