[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Systemd biting CUPS

On Sat, 7 Jun 2014 11:04:15 +0100, Brian wrote:
> On Fri 06 Jun 2014 at 16:39:22 +0200, Siard wrote:
> > For a couple of weeks now, printing with CUPS does not work in
> > Jessie after booting with systemd.
> > However: after booting with SysVinit, everything works fine.
> Is this with 'init-/bin/systemd' or is systemd-sysv installed. Not
> that it particularly matters, it's just part of the picture.

'init=/bin/systemd' is added to the kernel command line.
A second entry for jessie in /boot/grub/grub.cfg without it enables me
to boot with SysVinit.

> > With systemd, upgrading showed lots of errors concerning CUPS.
> > The problem is described here:
> > www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1208054.html
> > Those errors have gone lately, but printing still doesn't work with
> > systemd, even though the site mentions that it should be fixed in
> > CUPS 1.7.1-11, whilst CUPS in Jessie is already at 1.7.2-3.
> If the errors are gone the bug is fixed.

Error messages during an upgrade is what I meant here.

> > E.g., LibreOffice sees no printers, it only lists a 'generic
> > printer' and the CUPS interface at http://localhost:631 is
> > unreachable.
> Is this your specific problem? I can think of reasons for it with
> printer discovery over a network but the 'works with sysvinit but not
> with systemd' wouldn't be part of the solution.

It's just a locally connected printer. CUPS worked (after booting with
systemd) until some upgrade, a few weeks ago.

> > It strikes me that I have not seen it mentioned in this list yet.
> > Doesn't it affect others and is there perhaps an easy solution that
> > I'm missing?
> A minimal Wheezy install upgraded smoothly to Jessie here and
>    lpstat -a
> shows the print queues on a cups 1.7 server.

After booting with SysVinit:

$ lpstat -a
HL5240 accepting requests since vr 28 jun 2013 19:08:19 CEST
PDF accepting requests since ma 05 apr 2010 22:49:03 CEST

HL5240 (Brother) is the connected printer.
PDF refers to cups-pdf.

However, after booting with systemd:

$ lpstat -a
lpstat: Bad file descriptor

Reply to: