[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: where is my WiFi card? (ThinkPad T61)

You're now attacking the manufacturers?

What a troll you are!

Divorce has certainly exacted a heavy toll on you.

Your ex-wife did the right thing when she left you for a better guy.

Alright, you can now seek solace in booze.

From: Jerry Stuckle <jstuckle@attglobal.net>
To: debian-user@lists.debian.org
Sent: Saturday, June 7, 2014 2:31 AM
Subject: Re: where is my WiFi card? (ThinkPad T61)

On 6/6/2014 2:31 PM, Stanisław Findeisen wrote:
> On 2014-06-06 14:39, Jack Wilborn wrote:
>> I guess that's funny, I configure my wifi in the interfaces file... Oh
>> well... I know I had lots of problems with configuring of my wireless
>> interfaces mostly because they were proprietary chip sets.  I guess you
>> are loading a 'blob', the term used for the extracted firmware of the
>> manufacturers software.
>> The 'wireless-tools' package is the best to interface with as the 'iw'
>> commands are very useful.  I will try and dig my notes up with the
>> commands that I used and post them for you..
>> It seems like you should be able to at least figure out where the wifi
>> is connected, i.e. usb or pci buss, I bet on the pci buss as it's faster
>> I believe...
>> Jack
>> On Fri, Jun 6, 2014 at 12:01 AM, Stanisław Findeisen
>> <stf.list.debian.user@eisenbits.com
>> <mailto:stf.list.debian.user@eisenbits.com>> wrote:
>>      On 2014-06-05 23:08, Jack Wilborn wrote:
>>      > Might be that the wireless is 'wlan0' instead.  Might want to look at
>>      > your config files to see it it's being used.  The items you are using
>>      > (like 'lsusb', I assume you used 'lspci -vv' or something like
>>      that) are
>>      > tools that read all ports, and usually the wifi stuff is located on a
>>      > psi connection (does not have to be)..
>>      >
>>      > What installation stuff did you do?  (like 'wireless-tools') that
>>      should
>>      > give you some indication of if it's working. Plus I think the 'lo' is
>>      > the local loopback.
>>      >
>>      > Jack
>>      According to the wiki:
>>      https://wiki.debian.org/WiFi/HowToUse#NetworkManager , when using
>>      NetworkManager, the wireless interface should not be referenced within
>>      Debian's /etc/network/interfaces file.
>>      So I didn't take any configuration steps, besides installing (aptitude)
>>      the packages:
>>      firmware-iwlwifi (non-free)
>>      network-manager
>>      network-manager-gnome
>>      network-manager-kde
>>      wireless-tools
>>      wpasupplicant
>>      and their dependencies.
>>      I am using KDE. It says that network-manager-kde:
>>      https://packages.debian.org/stable/network-manager-kde is a dummy
>>      package, and that network-manager-gnome:
>>      https://packages.debian.org/stable/network-manager-gnome works in KDE
>>      too. But I can't see a systray applet anywhere, unless I run nm-applet
>>      from the command line.
>>      I also disabled openvpn on startup (I think it was installed as one of
>>      the dependencies).
>>      openvpn                  0:off  1:off  2:off  3:off  4:off  5:off
>>      6:off
> I'm sorry, but it was simply disabled in the BIOS config. :)
> The reason I couldn't find the right configuration switch was that it
> was in Security -> I/O Port Access, instead of Config -> Network.
> This + a proper stanza in /etc/network/interfaces solved the issue. No
> NetworkManager needed.

LOL, don't you just LOVE how manufacturers make those settings
"intuitive"?  :)


To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
[🔎] 53920908.8090500@attglobal.net" target="_blank">https://lists.debian.org/[🔎] 53920908.8090500@attglobal.net

Reply to: