[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libc-bin, libc-bin-amd64 conflict (Solved)

On 04/26/2014 02:57 AM, Andrei POPESCU wrote:
On Vi, 25 apr 14, 17:29:13, Gary Roach wrote:
When running Aptitude,  a red bar in the bottom half of the screen
"Unable to resolve dependencies". If I hit "g" after I update package list
and  Mark Upgradable, the top of the screen lists:
     iB      libc-bin
     pBA   libc-bin:amd64
The red box in the center of the screen says: No solution to these
descrepency problems exists!
At this point Aptitude is essentially frozen.

Attempts to run dpkg produce:
     root# dpkg -i libc-bin
     dpkg: error processing libc-bin (--install): cannot access archive: No
such file or directory
     Errors were encountered while processing: libc-bin
This can't work, because 'dpkg -i' needs files (not package names).
Please provide the output of:

dpkg --print-architecture
dpkg --print-foreign-architectures
apt-cache policy
apt-cache policy libc-bin
aptitude --simulate safe-upgrade
aptitude --simulate full-upgrade

I'm assuming your package lists are updated, otherwise please run
'aptitude update' (or press 'u' in interactive mode) first.

Kind regards,
I ran your suggestions. When aptitude --simulate worked OK, I decided to run a dpkg upgrade and it worked. I found that something was wrong with Aptitude. I purged Aptitude using apt-get and reinstalled the package. Everything now works fine. Thanks for your help.

Gary R

Reply to: