[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: compiling a Debian package

On Wed, Oct 31, 2012 at 10:04 AM, lee <lee@yun.yagibdah.de> wrote:
> Andrei POPESCU <andreimpopescu@gmail.com> writes:
>> On Mi, 31 oct 12, 04:13:59, lee wrote:
>>> Just try it and you'll see.  Or you figure out how to do it and let me
>>> know.  Like I said, it worked, then there was an update and it doesn't
>>> work anymore, probably because they modified the NVIDIA drivers, though
>>> nobody knows.  I've sent a bug report and it has been ignored.
>> And the bug number is? (Yes, I already did look for it)
> 688714
>>> People
>>> suggested that we're now forced to switch to brokenarch and to use
>>> packages from unstable, which I tried a couple times, and it made things
>>> worse and didn't work and creates dependency problems.
>> There's a famous quote from our current president from the time when he
>> was still the mayor of our capital[1], which I'll paraphrase to you:
>>     testing is not stable ;)
> Yeah and that's why you are forced to turn your system into a mess with
> brokenarch and are supposed to try packages from unstable which create
> only more dependency problems and mess things up even further.
> Think it through and you'll see that there won't be a next stable
> release unless they fix the mess they made --- and they're not going to
> do that.  Stable is obsolete and deprecated.

If testing never had any breakage, why would anyone bother with
stable?! Anyone reasonable knows that they have to expect problems
when using a version of ANYTHING that's labeled testing and especially
in this particular case where its sole purpose is to debug the next
version of Debian.

If you consider stable obsolete and are unhappy with testing, maybe
you should try a more fast-moving distribution or a rolling
distribution where there MIGHT be less breakage than in testing.

In this thread and in your bug report, you're more interested in
whining and criticizing than in fixing your system. AFAICT, you've
been advised to install packages from experimental and you haven't.

Furthermore, you may have been having a bad day but, over and above
your misunderstanding of the purpose of testing, your syadmin skills
are suspect since you're not sure whether you need xserver-xorg [1],
uninstall it [2], and are surprised that you have to re-install it [3,4] in
order to run X and they don't inspire confidence that you're up to
running testing.

1. "Libxvmc1 is installed because xserver-xorg-video-openchrome (which
I don't need) depends on it, and xserver-xorg-video-openchrome is
installed because xserver-xorg (which I probably need) depends on it."

2. "BTW I have removed the xserver-org package"

3. "startx says it cannot find /usr/bin/X. It actually doesn't exist
--- has that been moved or what happened to it?"

4. "I found I needed to re-install xserver-xorg"

Reply to: