[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: No sound on Wheezy

On Fri, Oct 26, 2012 at 2:20 PM, Darac Marjal <mailinglist@darac.org.uk> wrote:
> On Fri, Oct 26, 2012 at 01:53:05PM +0200, Artifex Maximus wrote:
>> Thank you. Where those hw numbers come from? I tried the following under Gnome:
> The parameters to "hw:x,y" are X = Card number and Y = Device on that
> card. I think I misread your output of aplay -l earlier. Looking at the
> one at the end of this email, I see you actually have "hw:0,0" (the
> ALC887-VD Analog), "hw:0,1" (the ALC887-VD Digital) and "hw:1,3" (the
> HDMI 0). Hopefully you can see how I've worked out those device names
> from the output?

Thanks for make that clear.

> If you're wanting to use the analog output (i.e. normal, metal cables),
> then we still have an issue. I notice that pulseaudio gave a warning
> when you tried to stop it; "pulseaudio -k" should kill any
> user-initiated daemons.
> To be sure, try running "sudo lsof|egrep 'snd|dsp|NAME'" to see if
> anything else is using your sound device.

I expand the command a little and the result is:

# lsof +c0 | egrep 'snd|dsp' | cut -d' ' -f1 | sort | uniq

I changed my pulseaudio to system mode instead of user mode in
/etc/default/pulseaudio. Now I have Built-in audio under system audio
settings and sound is working. In user mode there was no sound.
Permission problem? Do I need some special permission to use audio
device under pulseaudio?

Previously I reboot my system into single user mode and was able to
use speaker-test successfully. So ALSA definitely detect my card.
alsamixer master volume was 0 so I need to change before. Under Gnome
every audio slider is on max even alsamixer one. The output under
single user mode:

Hardware PCM card 0 'HDA Intel' device 0 subdevice 0
Its setup is:
  stream       : PLAYBACK
  access       : RW_INTERLEAVED
  format       : S16_LE
  subformat    : STD
  channels     : 2
  rate         : 48000
  exact rate   : 48000 (48000/1)
  msbits       : 16
  buffer_size  : 16384
  period_size  : 4096
  period_time  : 85333
  tstamp_mode  : NONE
  period_step  : 1
  avail_min    : 4096
  period_event : 0
  start_threshold  : 16384
  stop_threshold   : 16384
  silence_threshold: 0
  silence_size : 0
  boundary     : 4611686018427387904
  appl_ptr     : 0
  hw_ptr       : 0

speaker-test 1.0.25

Playback device is hw:0,0
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 16384
Period size range from 32 to 8192
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
 0 - Front Left
 1 - Front Right

In short. Under single user mode I am able to use speaker-test after
setting master volume to non zero value. Under Gnome there is sound in
system mode pulseaudio but no sound in non system mode.


Reply to: