[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re:[SOLVED] virt terminal font problem

Ivan and group. I went ahead and tried resetting the "radeon modeset] to 0 which is linux for [OFF], and voila' it worked. Shazaam! What do you know. I was afraid I was going to hose it all up but nope, it came up just like it was 'sposed to. Ivan, thank you for your help, so much. I'd gone nuts trying to google the answer to this mess and you directed me to the correct procedure.

I've been upgrading wheezy almost every day and it seems like once a week there is a group of messages that I had never received before in Lenny stating that I needed more radeon drivers or firmware or something and I had even hunted to see if I could find them but no joy there either. So hopefully since I'm not loading the radeon driver anymore, at least the radeonFB one I am guessing, maybe I won't get those messages any longer.

Again, Ivan thank you.  You were a great help.

On 09/05/2011 04:12 PM, Whit Hansell wrote:
[Having to resend this as I originally only sent it to Ivan - this is to the user group] Thanks for the reply Ivan. Shawn mentioned trying dpkg-reconfigure console-setup so I tried that first and got nowhere but it did give me a notice when I set it in certain setups, as in VGA. It came up w. this notice.....

Please select the size of the font for the Linux console. Simple │ │ integers corresponding to fonts can be used with all console drivers. │ │ The number then represents the font height (number of scan lines). │ Alternatively, the font may be represented as HEIGHTxWIDTH; however, │
 │ such font specifications require the kbd console package (not       │
│ console-tools) plus framebuffer (and the RadeonFB kernel driver for
 │ framebuffer does not support them either).       │
 │       │
│ Font heights can be useful for figuring out the real size of the symbols │ │ on the console. For reference, the font used when the computer boots has │
 │ size 16.

So, on the next page I set the font size to 16 and rebooted just for grins and it made no difference.

But on your suggestion, I looked at etc/modprobe.d and found.....

root@greatstar:/etc/modprobe.d# cat radeon-kms.conf
options radeon modeset=1

I'm guessing that if I change the options radeon modeset from 1 to 0, then the radeon drivers won't load on reboot. Then the standard framebuffers situation would occur? BTW my video driver is onboard and is an ATI RV610 if that helps at all.

Do you think I'm correct in the idea of changing the modeset from 1 to 0 and would I have problems by doing so? Thanks for your help. I know i sound goofy but I did a safe upgrade today in the midst of this mess and a cups file was upgraded and it hosed my printing up. So far I have printed from the web and can get noting but black, not blank, but black pages. <G> YOu can understand why I'm a bit spooky. <G>

Thanks for your help Ivan.  I really  appreciate it.

On 09/05/2011 01:25 AM, Ivan Shmakov wrote:
Whit Hansell<skipper44@comcast.net>  writes:

>  I had a problem when I purchased a new monitor, an LCD, and it
>  required me to put "vga=785" at the end of the Kernel line in
>  menu.list file in order to get any video out of the Virtual Terminal
>  (F1-6).  Now that I have reinstalled w. Wheezy, I have the Virtual
>  Terminal but the font size is extremely tiny.  I cannot see it well
>  at all and I have a vision problem to start with.

    Newer Linux&  userland VT tools' default is to use video card's
    graphics mode via a framebuffer console driver, instead of the
    text mode, which was the older default.

    My guess is that blacklisting the framebuffer drivers in
    modprobe.d(5) will allow one to use the text mode as before, but
    I haven't tried it yet.  (I currently have no access to a
    hardware running Wheezy.)

    It's also possible to use the Terminus fonts (as of
    console-terminus, IIRC), e. g.:

$ setfont -f /usr/share/consolefonts/Uni3-TerminusBold28x14.psf.gz

    Depending on the actual screen resolution, a font of up to 32x16
    pixel size may be chosen.

>  This problem w. terminal starts after boot when it gets to a certain
>  point, I'm assuming init.d, but not sure.  While it's trying to check
>  hardware items it's fine, the standard 80 X 25 large font terminal
>  screen.  Then all of a sudden it changes to the small/tiny font

    … And it's the time the framebuffer drivers get loaded.

>  and just before it brings up the splash screen, it sometimes messes
>  up the whole screen and puts across the top of the screen garbled
>  lines for just a second, then the splash screen pops up and I have no
>  problem logging in.

    Note also that since newer reboot(8) doesn't go through the BIOS
    (it only reinitializes the kernel), the screen will be garbled
    at reboot as well.


Reply to: