[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Transfering large files (was: Unison hangs on copy)

On Tue, Jul 26, 2011 at 03:24:11PM +0200, Claudius Hubig wrote:
> Victor Munoz <vmunoz@macul.ciencias.uchile.cl> wrote:
> >
> >So I tried rsyncinc another file, 23 M in size (with --progress
> >option), and surprise, it stops when 11% transfer is reached. Tried
> >with scp, and same magic number: 11% and it stops.
> What happens if you try to copy this file locally or on some other
> device or force reading it with, for example, dd (dd
> if=/path/to/yourfile of=/dev/null). Maybe the storage device on which
> it is located has some bad blocks. You could also try to run scp
> within strace to see where or what hangs.

Ok, I will try this and your other suggestions when I'm home later in
the day, since I don't have access to that machine now.

> >So now I think I have a problem with transfering large files. Somehow
> >the upgrade caused this, because almost all previous transfers
> >involved that 20M file, but now I am unable to copy this and other
> >large files between both machines. 
> Is only this one file the problem or maybe other files as well? What
> happens if you copy (not move!) that file to another location on your
> drive and then try to scp it over? 

After I noticed unison had problems with this file, I took another
file, about the same size, in other directory, and did the rsync and
scp experiments with those files. So I don't think it is a problem
with that particular file or disk sector. But I will check your other
suggestions as soon as I can.



Reply to: