[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Use Debian lenny package on Debian squeeze



Dear Alex,

Sorry for the late reply, I was away a few days. I am pretty sure it is squeeze 
but it was lenny before and has been updated to squeeze recently.

Here is the output of lsb_release -a:

No LSB modules are available.
Distributor ID:    Debian
Description:    Debian GNU/Linux 6.0 (squeeze)
Release:    6.0
Codename:    squeeze

And the content of /etc/apt/sources.list:

# squeeze
deb     http://ftp.ch.debian.org/debian/    squeeze main contrib non-free
deb-src http://ftp.ch.debian.org/debian/    squeeze main contrib non-free
# unstable
#deb    http://ftp.ch.debian.org/debian/    unstable main contrib non-free
#  Security updates
deb     http://security.debian.org/        squeeze/updates  main contrib no
n-free
deb-src http://security.debian.org/        squeeze/updates  main contrib no
n-free
# dotdeb
deb    http://packages.dotdeb.org        stable all
deb-src    http://packages.dotdeb.org        stable all

Hope this helps. Let me know if you need anymore information.

Regards



----- Original Message ----
From: Alex Mestiashvili <alexander.mestiashvili@biotec.tu-dresden.de>
To: debian-user@lists.debian.org
Sent: Fri, March 11, 2011 5:42:22 PM
Subject: Re: Use Debian lenny package on Debian squeeze

On 03/11/2011 05:50 PM, ML mail wrote:
> As you suggested I installed the package dependencies for Bacula using the
> packages for squeeze, which went fine for some packages but not for the
> libsqlite3-dev pacakge asou you can see here:
>
> # apt-get install libsqlite3-dev
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>   libsqlite3-dev : Depends: libsqlite3-0 (= 3.7.3-1) but 3.7.4-2 is to be
> installed
> E: Broken packages
>    
This is strange , are you sure that it is squeeze ? , what does  
lsb_release -a  say ?
could you please post here the content of /etc/apt/sources.list

> Do you have any idea how I can resolve this problem?
>
> Regards
>
>
>
>
> ----- Original Message ----
> From: Alex Mestiashvili<alexander.mestiashvili@biotec.tu-dresden.de>
> To: debian-user@lists.debian.org
> Sent: Fri, March 11, 2011 4:04:01 PM
> Subject: Re: Use Debian lenny package on Debian squeeze
>
>
> On 03/11/2011 04:40 PM, ML mail wrote:
>    
>> Dear Alex,
>>
>> Many thanks for your answer and great help. I tried the second variant
>>      
> (getting
>    
>> bacula 2.4 from the sources of lenny) and saw that there are all these
>> dependencies:
>>
>>      
> You are welcome
>    
>> pkg-checkbuilddeps: Unmet build dependencies: libjconv-dev libsqlite0-dev
>> libsqlite3-dev libmysqlclient15-dev libpq-dev postgresql-server-dev-8.3 |
>> postgresql-server-dev-8.2 libwrap0-dev python-dev libgtk2.0-dev (>= 2.10)
>> libgnome2-dev libwxgtk2.6-dev libacl1-dev libkrb5-dev libgnomeui-dev
>>      
> libx11-dev
>    
>> mtx bc libxt-dev libqt4-dev libqwt5-qt4-dev
>>
>> Do you know what is the procedure for all the dependencies? Do I need for all
>> of
>> these to do a "apt-get source oldpackage=oldversion" and build them using
>>
>>      
> usually higher versions are ok  ( if the api of the new versions aren't
> totally changed )
> As you can see for some of them you should have greater than * version -
> libgtk2.0-dev (>= 2.10) for example .
>
> So I would try with current versions from squeeze .
>
> if you don't want to install all the development stuff to the server
> than try pbuilder .
> It will create a minimal necessary build environment , install all
> dependencies , build
> the package , and clean up it the after all .
> But you should mention that you need to build package for squeeze and not
> for sid (unstable) which is used by default.
>
>    
>> debuild?
>>
>> Regards
>>
>>
>>
>>
>> ----- Original Message ----
>> From: Alex Mestiashvili<alexander.mestiashvili@biotec.tu-dresden.de>
>> To: debian-user@lists.debian.org
>> Sent: Fri, March 11, 2011 2:33:15 PM
>> Subject: Re: Use Debian lenny package on Debian squeeze
>>
>> On 03/11/2011 12:41 PM, ML mail wrote:
>>
>>      
>>> Dear Debian users,
>>>
>>> I would like to know if it is possible to use a Debian lenny package on a
>>> Debian
>>> squeeze installation and if yes how (what apt-get commands and/or
>>>
>>>        
>> modifications
>>
>>      
>>> in sources.list)?
>>>
>>>
>>> Let me explain why: I am using Bacula to do backups on a Debian lenny box 
and
>>> upgraded one server being backed up to Debian squeeze. Since then the 
backups
>>> are not running because Debian squeeze uses Bacula version 5.0 and the 
backup
>>> server (lenny) uses Bacula version 2.4. It is know that these two versions
>>>        
> are
>    
>>> not compatible together anymore (rejected hello command error).
>>>
>>> So I was wondering if it is somehow possible to install the Debian lenny
>>> versions of bacula-common and bacula-fd packages on Debian squeeze...?
>>>
>>> Many thanks in advance for your help.
>>> Regards
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>        
>> one way is to specify in /etc/apt/sources.list lenny repository
>> and try to install from it
>> like apt-get install bacula-fd -t lenny , but in case of bacula
>> which has many dependencies that probably will not work
>>
>> another way ( I prefer that one )  is to get the sources for the old
>> bacula-*
>> and compile them on squeeze
>>
>> you also need to define
>> deb-src pointing to the lenny repository
>> like  deb-src http://ftp.de.debian.org/debian/       lenny  main contrib
>>
>> than run something like that
>> mkdir /tmp/bacula
>> cd /tmp/bacula
>> apt-get source bacula-fd
>> cd bacula-$version
>>     debuild -us -uc
>>
>> you need devscripts package or pbuilder or ..
>> most probably you don't have all dependencies , so you'll need to
>> install them .
>> when all dependencies are satisfied it will (or will not ) build the
>> package which you can
>> install  on squeeze .
>>
>> and the 3'rd case is to update your bacula-director on lenny with
>> bacula-director -5.0 from http://backports.debian.org .
>> Anyway one day you'll need to upgrade to squeeze .
>>
>> Regards ,
>> Alex
>>
>>
>>
>>      
>
>    


-- 
Alexander Mestiashvili
System Administrator BIOTEC TU-Dresden
Tatzberg 47-51
01307 Dresden Germany
phone: +49-351-463-40070
email: alexander.mestiashvili@biotec.tu-dresden.de



-- 
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org 
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4D7A5EFE.6080807@biotec.tu-dresden.de">http://lists.debian.org/4D7A5EFE.6080807@biotec.tu-dresden.de



      


Reply to: