[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Error installing Squeeze with root filesystem as btrfs



On 9 January 2011 12:37, Pascal Hambourg <pascal.mail@plouf.fr.eu.org> wrote:
> Paul Richards a écrit :
>>
>> I figured out how to add crc32 to the initramfs, but unfortunately I
>> get the same error.  It's unfortunate that the error message does not
>> tell me which symbol is missing, as perhaps including another modulre
>> in the initramfs would help.
>
> Did you look at the output of dmesg as the message suggested ?
> The initramfs should start a shell after failing to mount the root
> filesystem (be patient, this may take some time).
> In the installer/rescue shell, you could also check the module
> dependency with lsmod.
>

I tried this procedure again but used a shotgun approach to picking
which extra modules to put into the initramfs.

>From the installer VT (at step 3 in my procedure above) I executed:

lsmod | sed 's%[ \t].*$%%' >> /etc/initramfs-tools/modules

This has probably led to a bloated ramfs, but the system now boots
with btrfs as the root filesystem. :)

Thanks everyone for your help.


-- 
Paul Richards
@pauldoo


Reply to: