Re: Lenny backports installation of one package only
> What reference?This reference. The reference I included.
Ok I didn't associate this part with what I was trying to do.
I would try first one then the other:
1. Use Roman Khomasuridze's suggestion:
> if you want to upgrade only iceweasel, then run2. Install the /etc/apt/preferences file as recommended. That will
> apt-get install iceweasel/lenny-backports
> by this, apt will try to install iceweasel from backports but will try to
> match its dependencies from lenny. it worked for me...
change the pinning rules.
Doing some further investigation it looks like it may be unsafe to install a later version of iceweasel as it seems to require a later version of a package which then breaks the older gnucash:
I looked at the man page for apt_preferences then added the following as a preferences file:
Pin: version 2.2.6-2
The idea is to keep gnucash at this version.
# aptitude -t lenny-backports install iceweasel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
The following packages are BROKEN:
The following NEW packages will be installed:
The following packages will be upgraded:
iceweasel libcairo2 libglib2.0-0 libnss3-1d libpixman-1-0 libsqlite3-0
The following packages are RECOMMENDED but will NOT be installed:
6 packages upgraded, 2 newly installed, 0 to remove and 106 not upgraded.
Need to get 13.2MB of archives. After unpacking 28.0MB will be used.
The following packages have unmet dependencies:
xulrunner-1.9.1: Breaks: gnucash (< 2.2.9-7~) but 2.2.6-2 is installed.
iceweasel-l10n-en-gb: Depends: iceweasel (<= 3.1) but 3.5.12-2~bpo50+1 is to be installed.
The following actions will resolve these dependencies:
Remove the following packages:
Upgrade the following packages:
iceweasel-l10n-en-gb [1:3.0.6+debian-1 (stable, now) -> 1:3.5.11+debian-1~bpo50+1
Leave the following dependencies unresolved:
gnucash-common recommends gnucash (>= 2.2.6-2)
Score is -11
Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
It looks like I need to review my decision not to upgrade gnucash. I didn't want to mess with this for various reasons (partly because I have a separate system which I use only for internet banking and I'd have to then add backports to this also. I suppose if it works ok this wouldn't be an issue. However I don't want to find out down the line that something fails and I have updated gnucash accounts using a version I can't continue with.)
Maybe I'll try Roman's suggestion.